Bug 433492 - hosted changes for user creation removal from registration
hosted changes for user creation removal from registration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Registration (Show other bugs)
rhn500
All Linux
low Severity low
: ---
: ---
Assigned To: Bryan Kearney
Grant Gainey
US=16436
:
Depends On:
Blocks: 240496 251909 430151 430153 433460
  Show dependency treegraph
 
Reported: 2008-02-19 11:58 EST by Pradeep Kilambi
Modified: 2013-01-10 04:18 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 16:00:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2008-02-19 11:58:36 EST
Description of problem:
TO remove the user creation from registration process against hosted, we need
hosted to return  appropriate message letting user know what to do.

The registration client makes an xmlrpc call to hosted when login/password is
entered. Which in turn calls backend/server/rhnUser.py's reserve_user method. In
Satellite Case this method returns a rhnFault that user creation is not allowed
in RHN Satellite context by checking 'disallow_user_creation' config variable
and if user exists. The same thing need to happen for hosted case as well.

- Flip the 'disallow_user_creation' flag in /etc/rhn/defaults/rhn_server.conf

- Fix the error message to suggest user to go to hosted url to create new user. 

- raise rhnFault which the client would catch and show the user to do the
appropriate thing.
Comment 2 James Bowes 2008-02-28 14:24:32 EST
Note: Make sure to let Pradeep/Satellite know when this is in the QA env
Comment 3 Amy Owens 2008-03-07 12:36:27 EST
aghhhh TUI-- chops off part of the message

There was an error communicating with the        # │ ┐
           │ │ registration server:                             ▒ │ │ 
           │ │                                                  ▒ │ │ 
           │ │ Error Class Code: 2001                           ▒ │ │ 
           │ │ Error Class Info:                                ▒ │ │ 
           │ │      We're sorry! Due to changes in the way we   ▒ │ │ 
           │ │ capture information, user                        ▒ │ │ 
           │ │      creation has been disabled through this     ▒ │ │ 
           │ │ process. To continue, please visit               ▒ │ │ 
           │ │      --                                          ▒ │ │ 
           │ │ https://www.redhat.com/wapps/ugc/register.html   ▒ │ │ 
           │ │ -- (you may copy and                             ▒ │ │ 
           │ │                                                    │ │ 
           │ │                      ┌────┐                        │ │ 
           │ │                      │ OK │                        │ │ 
           │ │                      └────┘          
Comment 4 Amy Owens 2008-03-07 12:40:37 EST
from rhnreg_ks  new message:
Error Class Code: 2001
Error Class Info: 
     We're sorry! Due to changes in the way we capture information, user
     creation has been disabled through this process. To continue, please visit
     -- https://www.redhat.com/wapps/ugc/register.html -- (you may copy and
     paste) and create a Red Hat login.

     To complete the process, run rhn_register on the command line and enter
     your new username and password when prompted. Our sincerest apologies for
     having you enter your new account information twice.
Comment 5 Amy Owens 2008-03-07 16:15:05 EST
all set on dev
Comment 6 Máirín Duffy 2008-03-10 17:26:53 EDT
I recommend against directing people to UGC. That's like telling them: "This
road's closed. Here, go this way" and redirecting them to a bridge that's out.
:) See, if they are creating brand new blank accounts using UGC, they will never
be able to successfully register because a brand new account will have 0
entitlements.

Better to point people to: https://rhn.redhat.com/rhn/sales/LoginInfo.do 
It was specifically designed for this purpose.

====

On the GUI screen with three buttons:

[o] I have an existing Red Hat Login
[ ] I dont have a login. I need to create one
[ ] Tell me why I need to register and provide a Red Hat Login

It should be changed to look like this:


[o] I have an existing Red Hat Login
[ ] Tell me why I need to register and provide a Red Hat Login

(i) Tip: Don't have a Red Hat Login? Please visit:
https://rhn.redhat.com/rhn/sales/LoginInfo.do

=========

Why Register? Screen also needs the language regarding creating a new login
completely taken out.
Comment 7 James Bowes 2008-03-11 14:46:12 EDT
I've updated the link to point at LoginInfo.do instead. The client side changes
to get rid of the create login checkbox will be in rhel 5.2 and 4.7, iirc
Comment 8 Amy Owens 2008-03-12 07:49:51 EDT
Here is the new message:
Error Class Code: 2001                           ▒ │ │ 
           │ │ Error Class Info:                                ▒ │ │ 
           │ │      We're sorry! Due to changes in the way we   ▒ │ │ 
           │ │ capture information, user                        ▒ │ │ 
           │ │      creation has been disabled through this     ▒ │ │ 
           │ │ process. To continue, please visit               ▒ │ │ 
           │ │      --                                          ▒ │ │ 
           │ │ https://rhn.redhat.com/rhn/sales/LoginInfo.do    ▒ │ │ 
           │ │ -- (you may copy and paste) and create a Red Hat login.         
▒ │ │ 
           │ │                                                  ▒ │ │ 
           │ │      To complete the process, run rhn_register   ▒ │ │ 
           │ │ on the command line and enter                    ▒ │ │ 
           │ │      your new username and password when         ▒ │ │ 
           │ │ prompted. Our sincerest apologies for            ▒ │ │ 
           │ │      having you enter your new account           ▒ │ │ 
           │ │ information twice.     
Comment 9 Pradeep Kilambi 2008-03-12 09:38:16 EDT
(In reply to comment #7)
> I've updated the link to point at LoginInfo.do instead. The client side changes
> to get rid of the create login checkbox will be in rhel 5.2 and 4.7, iirc


yep, rhel- 4.7 and 5.3
Comment 10 Grant Gainey 2008-03-17 12:44:13 EDT
Passes QA, 17-MAR

Note You need to log in before you can comment on or make changes to this bug.