Bug 433511 - vnc server through krfb and accessing by http broken
vnc server through krfb and accessing by http broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
: Reopened
Depends On: 433510
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 14:13 EST by Jeff Bastian
Modified: 2015-07-13 13:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: 3.5.9-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 13:25:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch for /usr/bin/krfb_httpd (436 bytes, patch)
2008-02-19 14:13 EST, Jeff Bastian
no flags Details | Diff
fixed /usr/bin/krfb_httpd (890 bytes, application/octet-stream)
2008-02-19 14:27 EST, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2008-02-19 14:13:48 EST
+++ This bug was initially created as a clone of Bug #433493 +++

When accessing by http://server:5800 to a shared desktop in kde with the krfb
program it fails with:

wc: /usr/share/vnc/classes/vncviewer.class: No such file or directory
cat: /usr/share/vnc/classes/vncviewer.class: No such file or directory


The problem is in the file /usr/bin/krfb_httpd in this line:
<APPLET CODE=VncViewer.class ARCHIVE=VncViewer.jar WIDTH=$width HEIGHT=$height>

It should be as follows:

<APPLET CODE=vncviewer/VNCViewer.class ARCHIVE=vncviewer.jar WIDTH=$width
HEIGHT=$height>
Comment 1 Jeff Bastian 2008-02-19 14:13:48 EST
Created attachment 295320 [details]
patch for /usr/bin/krfb_httpd
Comment 2 Jeff Bastian 2008-02-19 14:15:09 EST
This patch assumes the literal ^M chars have been fixed as described in bug 433510
Comment 3 Jeff Bastian 2008-02-19 14:16:02 EST
This problem is with kdenetwork-3.5.8-9.fc8
Comment 4 Jeff Bastian 2008-02-19 14:27:09 EST
Created attachment 295323 [details]
fixed /usr/bin/krfb_httpd

Since diff gets confused by the ^M char, here is the entire file gzip'ed (to
prevent an ASCII attachment from also losing the ^M).
Comment 5 Lukáš Tinkl 2008-02-26 08:38:36 EST
Fixed in 3.5.9-2
Comment 6 Kevin Kofler 2008-02-26 15:11:20 EST
As per http://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow , the bug 
should be in MODIFIED state, not RESOLVED, as long as the update has not been 
pushed.
Comment 7 Fedora Update System 2008-02-28 16:37:07 EST
kdegames-3.5.9-1.fc7, kdesdk-3.5.9-1.fc7, kdeutils-3.5.9-1.fc7, kdeaccessibility-3.5.9-1.fc7, arts-1.5.9-1.fc7, kdeaddons-3.5.9-1.fc7, kdeartwork-3.5.9-1.fc7, kdebindings-3.5.9-1.fc7, kdegraphics-3.5.9-1.fc7, kdewebdev-3.5.9-1.fc7, kde-i18n-3.5.9-4.fc7, kdeadmin-3.5.9-1.fc7, kdeedu-3.5.9-1.fc7, kdemultimedia-3.5.9-1.fc7, kdenetwork-3.5.9-2.fc7, kdetoys-3.5.9-1.fc7, kdelibs-3.5.9-3.fc7, kdebase-3.5.9-1.fc7, kdepim-3.5.9-6.fc7, kdevelop-3.5.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdegames kdesdk kdeutils kdeaccessibility arts kdeaddons kdeartwork kdebindings kdegraphics kdewebdev kde-i18n kdeadmin kdeedu kdemultimedia kdenetwork kdetoys kdelibs kdebase kdepim kdevelop'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1892
Comment 8 Fedora Update System 2008-03-03 13:21:24 EST
kdevelop-3.5.1-3.fc7, arts-1.5.9-1.fc7, kdelibs-3.5.9-3.fc7, kdeaccessibility-3.5.9-1.fc7, kdeaddons-3.5.9-1.fc7, kdeadmin-3.5.9-1.fc7, kdeartwork-3.5.9-1.fc7, kdebase-3.5.9-3.fc7, kdebindings-3.5.9-1.fc7, kdeedu-3.5.9-1.fc7, kdegames-3.5.9-1.fc7, kdegraphics-3.5.9-1.fc7, kdemultimedia-3.5.9-1.fc7, kdepim-3.5.9-6.fc7, kdetoys-3.5.9-1.fc7, kdewebdev-3.5.9-1.fc7, kde-i18n-3.5.9-4.fc7, kdenetwork-3.5.9-2.fc7, kdesdk-3.5.9-1.fc7, kdeutils-3.5.9-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-03-03 13:25:51 EST
kdevelop-3.5.1-3.fc8, arts-1.5.9-1.fc8, kdelibs-3.5.9-3.fc8, kdeaccessibility-3.5.9-1.fc8, kdeaddons-3.5.9-1.fc8, kdeadmin-3.5.9-1.fc8, kdeartwork-3.5.9-1.fc8, kdebase-3.5.9-3.fc8, kdebindings-3.5.9-1.fc8, kdeedu-3.5.9-1.fc8, kdegames-3.5.9-1.fc8, kdegraphics-3.5.9-1.fc8, kde-i18n-3.5.9-4.fc8, kdemultimedia-3.5.9-1.fc8, kdenetwork-3.5.9-2.fc8, kdepim-3.5.9-6.fc8, kdesdk-3.5.9-1.fc8, kdetoys-3.5.9-1.fc8, kdeutils-3.5.9-1.fc8, kdewebdev-3.5.9-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.