Bug 433573 - RFE: add mixer and trash applett to the default panel config
RFE: add mixer and trash applett to the default panel config
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfce4-panel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 20:47 EST by Christoph Wickert
Modified: 2008-04-09 11:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 11:41:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add mixer and trash applets (2.50 KB, patch)
2008-02-19 20:47 EST, Christoph Wickert
no flags Details | Diff
Patch to make the systray borderless by default (201 bytes, patch)
2008-02-19 20:48 EST, Christoph Wickert
no flags Details | Diff

  None (edit)
Description Christoph Wickert 2008-02-19 20:47:35 EST
Description of problem:
1. Patch to add mixer and trash applets to the default panel config as proposed
by Rahul in http://sundaram.fedorapeople.org/spins/livecd-fedora-8-xfce.ks

2. Patch to make the systray borderless by default

Version-Release number of selected component (if applicable):
xfce4-panel-4.4.2-2.fc9

Additional info:
No need for an explicit Requires on xfce4-mixer or Thunar, the panel silently
removes missing plugins.

Nevertheless a requires for thunar may be useful because Thunar is in the bottom
panel by default and missing launchers are not removed automatically. On the
other hand the panel shows a clear error message if Thunar is not installed and
users are supposed to do groupinstalls anyway, so IMHO it is not really
necessary. One could even think about also droping the requirement for Terminal
and mouspad?

Screenshot is at http://cwickert.fedorapeople.org/screenshots/xfce-live-desktop.png

Comments?
Comment 1 Christoph Wickert 2008-02-19 20:47:35 EST
Created attachment 295363 [details]
Patch to add mixer and trash applets
Comment 2 Christoph Wickert 2008-02-19 20:48:42 EST
Created attachment 295364 [details]
Patch to make the systray borderless by default
Comment 3 Kevin Fenzi 2008-02-19 21:23:06 EST
So whats the rationale here? Rahul?

I guess I can see adding the mixer... the trash is already on the desktop
though, right? 

Why a borderless systray? 
Comment 4 Christoph Wickert 2008-02-19 21:47:25 EST
(In reply to comment #3)
> 
> Why a borderless systray? 

Because it looks better :)
Comment 5 Kevin Fenzi 2008-02-19 23:36:53 EST
well, not sure I agree. I kinda like the border. ;) 
Comment 6 Rahul Sundaram 2008-02-20 01:23:14 EST
This is probably a matter of preferences in workflow but Trash in the desktop
IMO is a fairly useless thing. Minimizing the desktop to click on icons on them
seems disruptive as compared to clicking on the panel icon. I would prefer we
lose all desktop icons by default and put in the trash, mixer, date plugins and
"places" menu so users don't have to minimize all their apps ever to reach their
desktop unless they have personal data they might want to access that way. 

We should probably consider disabling the tips and trick popup by default too.
It isn't too useful for end users and increases the login time. Most of them
tend to disable it asap anyway. 
Comment 7 Rahul Sundaram 2008-02-20 01:32:18 EST
Oh btw, I haven't suggested the borderless sys tray and the border serves a
functional purpose of separating panel icons from sys tray apps atleast on
panels that support it. Maybe tweak the border to look more elegant instead of
eliminating it entirely though I am not sure how much of a difference that makes. 
Comment 8 Christoph Wickert 2008-02-21 11:49:50 EST
(In reply to comment #6)
> This is probably a matter of preferences in workflow but Trash in the desktop
> IMO is a fairly useless thing. Minimizing the desktop to click on icons on them
> seems disruptive as compared to clicking on the panel icon. I would prefer we
> lose all desktop icons by default and put in the trash, mixer, date plugins and
> "places" menu so users don't have to minimize all their apps ever to reach their
> desktop unless they have personal data they might want to access that way. 

+ 1

We could add the places plugin to the panel by default and making it default in
comps. If it's not installed it will be automatically removed from the panel. If
we decide to add the places plugin we could remove the trash applet and still
have two options to reach trash (desktop and places).

We could think about extending the default panel config further, take a look at
the xubuntu desktop for example.
http://cwickert.fedorapeople.org/screenshots/xubuntu-desktop.png
Looks quite similar to the Gnome desktop and for me it's kind of more complete
than our default install.

(x)ubuntu has a patch which lets you configure which icons are shown on
xfdesktop. See 
http://cwickert.fedorapeople.org/screenshots/xfdesktop-special-icon-config.png
for a screenshot. Unfortunately this only works after logout and the patch need
some ui love and translations, so I don't think we should apply it yet.

> We should probably consider disabling the tips and trick popup by default too.

+ 1

(In reply to comment #7)
> Oh btw, I haven't suggested the borderless sys tray and the border serves a
> functional purpose of separating panel icons from sys tray apps atleast on
> panels that support it. Maybe tweak the border to look more elegant instead of
> eliminating it entirely though I am not sure how much of a difference that makes. 

From what I know from my plugins this is not possible. If we need some
separation we could add seperators left and right.

From right to left the order of the plugins atm is trash, mixer and systray, see
http://cwickert.fedorapeople.org/screenshots/xfce-live-desktop.png
I did that because when the systray on the right the other plugins will change
their position depending on how many apps sit in the tray.

Proposals for yet another panel config or is everybody fine with the current one?
Comment 9 Kevin Fenzi 2008-02-21 21:58:20 EST
I can see wanting the trash and mixer in the panel. The workflow seems to make
sense to have them there. 

I'm not sure making Xfce look like gnome is something we want... or at least
something I want. ;) 

For tips and tricks, how about re-vamping them to include things that are
usefull? We could put: 
http://docs.fedoraproject.org/release-notes/f7/en_US/sn-PackageNotes.html#id3181196

and possible some fedora related things like how to get help, or pointers to the
docs, etc? 
I agree the current tips are not very usefull. 

Comment 10 Rahul Sundaram 2008-02-22 02:11:40 EST
The current upstream default layout seems to be only there for people nostalgic
about the old CDE look alike that Xfce was in the past. The Gnome panel layout
definitely seems to be more good for migrants as well as from a pure
functionality perspective. Even if we don't change the layout entirely. Consider
atleast these two things in addition to trash and mixer

Date plugin
Places menu

If you push the places menu by default, I think the application menu is just a
good complimentary fit. 

If the tips were more oriented towards Fedora, end users are definitely going to
find it more helpful than the current ones. 
Comment 11 Kevin Fenzi 2008-03-01 21:08:16 EST
Well, partly I like the upstream default because it's spare... I don't use a GUI
trash for example, as 'rm' works fine for me.  :) 

One other thing here is that we are just kinda flailing around... 
Do we have any idea what users might want and why? 

Perhaps we could do some mockups with various setups and ask on the fedora
and/or fedora-devel lists for people to give feedback? 
Or perhaps we could move the discussion upstream and see if they are willing to
revisit the default layout?

I guess I don't have a problem including: 

trash, mixer, date, and places however if someone wants to cook up a patch for
that. 
Comment 12 Kevin Fenzi 2008-04-08 14:25:07 EDT
Christoph: Any chance you could make up a patch for trash, mixer, date & places?

I will try and find time to do so, but I'm pretty swamped right now. ;( 

Also, freeze is today, so I don't know if we could get this change into f9, but
we could try I suppose. 
Comment 13 Christoph Wickert 2008-04-08 18:48:15 EDT
(In reply to comment #12)
> Christoph: Any chance you could make up a patch for trash, mixer, date & places?

Date and places require plugins which would require changes in comps. Also both
plugins kind of conflict with the default panel config. If we include
Datetime-plugin we should get rid of the normal clock plugin. Adding places to
the bottom panel is confusing because we are already using the same icon there
for Thunar. IMO adding places only makes sense in the top panel and means to
switch to a more Gnomisch approach: Xfce-menu named "Applications" on the right
and places menu with the label "Places" next to it.

This is worth discussing it on the desktop list. For now I suggest we stick with
my patch from comment #1.
Comment 14 Kevin Fenzi 2008-04-08 22:19:42 EDT
Sounds good. 
Commited the patch from comment #1 and built. 

http://koji.fedoraproject.org/koji/taskinfo?taskID=558824

Mailed rel-eng to see if they will tag it into f9. 

Should we keep this bug open for further discussion moving forward? 
Or close it and do a new one in the f10 cycle for further changes?
Comment 15 Rahul Sundaram 2008-04-09 08:12:02 EDT
If nothing more is intended for Fedora 9, the main intend of this ticket is
resolved and we can open new ones for Fedora 10. 
Comment 16 Kevin Fenzi 2008-04-09 11:41:48 EDT
Yeah, I don't think we are going to be able to get any further changes in F9 at
this point... we should look at F10. 

I guess one advantge to setting up a Xfce SIG would be that we could better
track these ideas and discuss them in regular meetings, etc. 

I'll go ahead and close this now, and we can reopen or file a new one for F10?

Note You need to log in before you can comment on or make changes to this bug.