Bug 433606 - t: progress.c:972: create_image: Předpoklad „p - bp->buffer <= bp->width“ nesplněn.
t: progress.c:972: create_image: Předpoklad „p - bp->buffer <= bp->width“ nes...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
: 431084 438963 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-20 05:13 EST by Adam Tkac
Modified: 2013-04-30 19:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 05:33:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core dump (600.00 KB, application/octet-stream)
2008-02-20 05:14 EST, Adam Tkac
no flags Details

  None (edit)
Description Adam Tkac 2008-02-20 05:13:08 EST
Description of problem:
when I download files wget is terminated with SIGABRT sometimes.

Version-Release number of selected component (if applicable):
rpm -q wget
wget-1.11-1.fc9.i386

How reproducible:
sometimes

Steps to Reproduce:
1. try download something
2. wait for assertion fail
  
Actual results:
abort

Expected results:
successful download

Additional info:
Corefile is attached. If you need one from binary compiled without optimizations
let me know.
Comment 1 Adam Tkac 2008-02-20 05:14:15 EST
Created attachment 295412 [details]
core dump
Comment 2 Karsten Hopp 2008-02-20 10:18:23 EST
this looks like this bug which has been fixed in wget-1.11.1-prerelease:
 - Wget should no longer abort with an assertion error for some locales,
when (somewhat) large files are downloaded, with the "bar" progress
output mode.
Comment 3 Mamoru TASAKA 2008-02-25 12:41:54 EST
... This seems to be actually duplicate of the bug I reported
 (bug 431084) ...
Comment 4 Karsten Hopp 2008-03-26 12:32:03 EDT
*** Bug 438963 has been marked as a duplicate of this bug. ***
Comment 5 Karsten Hopp 2008-03-26 12:34:13 EDT
*** Bug 431084 has been marked as a duplicate of this bug. ***
Comment 6 Karsten Hopp 2008-03-31 05:33:39 EDT
I've built wget-1.11.1 in rawhide which is supposed to fix this issue. Please
reopen if the same error shows up again with that version.

Note You need to log in before you can comment on or make changes to this bug.