Bug 433621 - Error in system-config-cluster tool
Error in system-config-cluster tool
Status: CLOSED DUPLICATE of bug 398291
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
Depends On:
  Show dependency treegraph
Reported: 2008-02-20 07:28 EST by Juan Ramon Martin
Modified: 2009-04-16 16:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-23 09:34:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Juan Ramon Martin 2008-02-20 07:28:18 EST
Description of problem:
When updating system-config-cluster to system-config-cluster-1.0.51-2.0 the
program does not start giving the following error:
~]# system-config-cluster
Traceback (most recent call last):
  File "/usr/sbin/system-config-cluster", line 52, in ?
    from ConfigTab import ConfigTab
  File "/usr/share/system-config-cluster/ConfigTab.py", line 27, in ?
    from ConfigTabController import ConfigTabController
  File "/usr/share/system-config-cluster/ConfigTabController.py", line 35, in ?
    from FaildomController import FaildomController
  File "/usr/share/system-config-cluster/FaildomController.py", line 213
    if val == "Yes" or val == "yes" or val="1":
SyntaxError: invalid syntax

Version-Release number of selected component (if applicable):

How reproducible:
Upgrade to version 1.0.51-2.0 and execute system-config-cluster

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
To correct it, the only thing that must be done is substitute val="1" by
val=="1" on file
"/usr/share/system-config-cluster/FaildomController.py", line 213
Comment 1 Jim Parsons 2008-04-23 09:34:25 EDT
This has been fixed in a z-stream release.

*** This bug has been marked as a duplicate of 398291 ***

Note You need to log in before you can comment on or make changes to this bug.