Bug 433623 - kernel oops in acpi_pm_read
kernel oops in acpi_pm_read
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-20 07:59 EST by Anthony Clark
Modified: 2008-02-21 09:33 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 09:33:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Clark 2008-02-20 07:59:56 EST
Description of problem:

kernel oops 

Feb 20 10:09:20 mjelectrical kernel: BUG: unable to handle kernel paging request
at virtual address 970ffe39
Feb 20 10:09:20 mjelectrical kernel: printing eip: c05a4c6e *pde = 00000000 
Feb 20 10:09:20 mjelectrical kernel: Oops: 0000 [#1] SMP 
Feb 20 10:09:20 mjelectrical kernel: Modules linked in: ipt_MASQUERADE
iptable_nat nf_nat nf_conntrack_ipv4 xt_state nf_conntrack nfnetlink ipt_REJECT
bridge xt_tcpudp iptable_filter ip_tables x_tables ext2 nfsd exportfs lockd
nfs_acl auth_rpcgss bnep rfcomm l2cap bluetooth irnet ppp_generic slhc irtty_sir
sir_dev ircomm_tty ircomm irda crc_ccitt autofs4 sunrpc cpufreq_ondemand loop
dm_multipath ipv6 snd_hda_intel snd_seq_dummy dvb_pll mt2060 snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device dvb_usb_nova_t_usb2
dvb_usb_dibusb_common snd_pcm_oss snd_mixer_oss dib3000mc snd_pcm dibx000_common
snd_timer snd_page_alloc snd_hwdep snd dvb_usb button soundcore usb_storage skge
k8temp hwmon dvb_core i2c_ali1535 i2c_ali15x3 i2c_core pcspkr serio_raw sr_mod
cdrom sg floppy pata_ali dm_snapshot dm_zero dm_mirror dm_mod ahci libata sd_mod
scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd
Feb 20 10:09:20 mjelectrical kernel: CPU:    1
Feb 20 10:09:20 mjelectrical kernel: EIP:    0060:[<c05a4c6e>]    Not tainted VLI
Feb 20 10:09:20 mjelectrical kernel: EFLAGS: 00210286   (2.6.23.15-137.fc8 #1)
Feb 20 10:09:20 mjelectrical kernel: EIP is at acpi_pm_read+0x0/0xf
Feb 20 10:09:20 mjelectrical kernel: eax: c071aa80   ebx: 127443b1   ecx:
bf80e784   edx: 14eacf87
Feb 20 10:09:20 mjelectrical kernel: esi: bf80e784   edi: 00000000   ebp:
0048bdbc   esp: f54d2f74
Feb 20 10:09:20 mjelectrical kernel: ds: 007b   es: 007b   fs: 00d8  gs: 0033 
ss: 0068
Feb 20 10:09:20 mjelectrical kernel: Process pulseaudio (pid: 3649, ti=f54d2000
task=f5b04c20 task.ti=f54d2000)
Feb 20 10:09:20 mjelectrical kernel: Stack: c0440d3c bf80e784 0000004e f54d2fa0
47bbfc50 127443b1 bf80e784 bf80e784 
Feb 20 10:09:20 mjelectrical kernel: 00000000 f54d2000 c043162c 00c11bac
bf80e784 bf80e784 bf80e784 081da2e0 
Feb 20 10:09:20 mjelectrical kernel: c040518a bf80e784 00000000 00c11bac
bf80e784 081da2e0 bf80e748 ffffffda 
Feb 20 10:09:20 mjelectrical kernel: Call Trace:
Feb 20 10:09:20 mjelectrical kernel: [<c0440d3c>] do_gettimeofday+0x31/0xd2
Feb 20 10:09:20 mjelectrical kernel: [<c043162c>] sys_gettimeofday+0x19/0x53
Feb 20 10:09:20 mjelectrical kernel: [<c040518a>] syscall_call+0x7/0xb
Feb 20 10:09:20 mjelectrical kernel: =======================
Feb 20 10:09:20 mjelectrical kernel: Code: 04 39 f7 72 db 39 f1 76 04 39 f9 72
d3 39 fe 0f 97 c0 39 ce 0f 92 c2 21 d0 a8 01 75 c3 5b 89 c8 5e 5f c3 e8 af ff ff
ff 31 d2 c3 <8b> 15 88 93 73 c0 ed 31 d2 25 ff ff ff 00 c3 83 ec 04 83 3d 00 
Feb 20 10:09:20 mjelectrical kernel: EIP: [<c05a4c6e>] acpi_pm_read+0x0/0xf
SS:ESP 0068:f54d2f74



Version-Release number of selected component (if applicable):
kernel-2.6.23.15-137.fc8 i686

How reproducible:
most likely i awoke display from power saving but unfortunately i had no
terminal open at the time so i wasn't informed immediately.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2008-02-20 19:26:01 EST
This is caused by memory corruption. It could be hardware failure, so run
memtest86 for at least a fewhours on the machine.
Comment 2 Anthony Clark 2008-02-21 09:33:27 EST
RAM CRC (BIOS) was off. 'memtest86' default settings had been run 10h. I will
resolve to NOTABUG on virtue of CRC off.

Note You need to log in before you can comment on or make changes to this bug.