Bug 433648 - evolution-exchange crashes when attempting to authenticate
evolution-exchange crashes when attempting to authenticate
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Milan Crha
desktop-bugs@redhat.com
:
: 391271 (view as bug list)
Depends On: 433469
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-20 12:07 EST by Matthew Barnes
Modified: 2009-09-02 05:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:14:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 361972 None None None Never

  None (edit)
Description Matthew Barnes 2008-02-20 12:07:30 EST
+++ This bug was initially created as a clone of Bug #433469 +++

Description of problem:
The evolution-exchange plugin crashes during the "Autheticate" stage of setting
up an account.

Version-Release number of selected component (if applicable):
evolution-exchange-2.12.3-1.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Set up an e-mail account for a mailbox on an Exchange server.
2. Fill out the OWA URL, click Authenticate.
3. Enter password.
  
Actual results:
Evolution crashed.

Expected results:
Access to mailbox.

Additional info:
See Bug Buddy report attached.

-- Additional comment from theholyettlz@googlemail.com on 2008-02-19 09:50 EST --
Created an attachment (id=295290)
Censored Bug Buddy report from evolution-exchange crash


-- Additional comment from mbarnes@redhat.com on 2008-02-20 10:34 EST --
Looks like libsoup is choking on a URI it doesn't like and Evolution is not
checking for error.  This appears to have been fixed in Evolution 2.21 so I can
backport the fix.

-- Additional comment from mbarnes@redhat.com on 2008-02-20 11:28 EST --
James, I built an updated evolution-data-server package with a patch based on
your  Bug Buddy report, but I haven't been able to reproduce the crash here so
the patch is untested.  Would you mind testing the package before I push it to
Fedora repos?

Updated package is here:
http://koji.fedoraproject.org/packages/evolution-data-server/1.12.3/3.fc8


-- Additional comment from theholyettlz@googlemail.com on 2008-02-20 11:51 EST --
Thanks, it no longer crashes.

-- Additional comment from mbarnes@redhat.com on 2008-02-20 12:04 EST --
Cool, I'll push it out to Fedora Updates then.

I'm still trying to reproduce this on our internal Exchange servers here but the
Authenticate step is working fine here.  I suspect it's related to your Outlook
Web Access configuration.  Do you know anything about it, or whether it's some
kind of non-standard configuration?

-- Additional comment from updates@fedoraproject.org on 2008-02-20 12:07 EST --
evolution-data-server-1.12.3-3.fc8 has been submitted as an update for Fedora 8
Comment 2 RHEL Product and Program Management 2008-02-20 12:17:16 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 RHEL Product and Program Management 2008-03-11 15:36:09 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 6 RHEL Product and Program Management 2008-07-21 19:06:28 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 Matthew Barnes 2008-08-31 15:45:06 EDT
Upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=361972

Fixed in Subversion revision 8357.
Comment 10 Milan Crha 2009-03-09 12:07:51 EDT
*** Bug 391271 has been marked as a duplicate of this bug. ***
Comment 11 leo 2009-03-20 08:41:48 EDT
Seems RHEL is not appropriate for desktop environment, I am using debian and ubuntu at home, and no complains at all.
Comment 17 David Ward 2009-07-14 08:36:42 EDT
Matthew, I applied the patch for that bug from upstream to the source RPM and built it, but it continues to crash for me.  Does that patch fix it for you?
Comment 18 Milan Crha 2009-07-31 03:58:48 EDT
(In reply to comment #17)
> Matthew, I applied the patch for that bug from upstream to the source RPM and
> built it, but it continues to crash for me.  Does that patch fix it for you?  

David, as far as I can tell it fixes the issue. Are you sure you are running proper evolution-data-server binary?
Comment 19 errata-xmlrpc 2009-09-02 05:14:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1259.html

Note You need to log in before you can comment on or make changes to this bug.