Bug 433676 - Cannot Delete mutiple System Profiles. Results in a 404 Error
Cannot Delete mutiple System Profiles. Results in a 404 Error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
high Severity medium
: ---
: ---
Assigned To: Mike Orazi
Amy Owens
US=18807
: Reopened
Depends On:
Blocks: 428922
  Show dependency treegraph
 
Reported: 2008-02-20 14:51 EST by Arlinton Bourne
Modified: 2009-03-26 16:50 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 16:50:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arlinton Bourne 2008-02-20 14:51:25 EST
Description of problem:
When selecting multiple systems, clicking Manage on the top right, then trying
to remove these systems the result is a 404 Page Not Found Error and the systems
 are not removed.

Version-Release number of selected component (if applicable):
Red Hat Network release 5.0.4

How reproducible:
Always

Steps to Reproduce:
1. Login
2. Click Systems
3. Select systems you'd like to delete 
4. Click Next  (>) so that the grey bar notices the amount of systems you select
(This is broken as well that will be in another bug).
5. Click Manage on the upper right
6. Click Misc or use the link on the Overview page to delete systems
7. Confirm your deletion

  
Actual results:
Get a 404 Error

Expected results:
Delete systems
Comment 1 Jie Chen 2008-02-21 12:03:09 EST
I could not reproduce the problem.  
I tried on both rhn.redhat.com and rhn.webqa.redhat.com (login as org admin),
and I was able to delete three system profiles without error.  I also tried
login as a normal user, and it worked too.
Comment 2 Arlinton Bourne 2008-02-26 13:30:37 EST
In trying to delete 95 systems the error is very reproducible. It takes quite
some time to actually delete systems.

The URL at the time was:
https://rhn.redhat.com/network/systems/ssm/misc/delete_systems_conf.pxt

After clicking "Confirm Deletions" the URL is the same and the 404 Error is there.




Comment 3 Arlinton Bourne 2008-02-26 13:32:03 EST
Clarification:
"It takes quite some time to actually delete systems."

Should be:
"It take quite some time in attempting to delete the systems."
Comment 4 Arlinton Bourne 2008-02-26 14:06:31 EST
Successful deletions with number of systems selected via WEB UI:
3,5,10,20,40,45

Unsuccessful deletions with number of systems selected via WEB UI:
50, 95

Note:
When trying to delete the systems there were 5 systems on the first page that
could not be selected. Thus this allowed for only 45 of the total 50 systems to
be selected for deletion. When deleting > 50 systems this included the 45 on the
first page and a selection of boxes on the second page.


Also when trying to delete 50 systems a 500 Internal Server Error popped up. I
am still investigating.
Comment 5 Arlinton Bourne 2008-02-26 14:07:59 EST
Re: 500 Internal Server Error
This occurred but the systems were deleted.
Comment 6 Arlinton Bourne 2008-02-26 14:24:44 EST
I've also tried with the last 83 systems. The result is the same as the attempt
to delete 95 systems. I'll hold off testing since these are the last 83 systems
and I'd like to keep a reproducible case hanging around for further investigation.
Comment 7 Sebastian Skracic 2008-06-19 09:07:29 EDT
Could not reproduce it either on 5.0.5 production or on 5.0.6 stage.  I have
successfully deleted a system set containing 45, 50, 85 and 105 servers.
Comment 12 Amanda Carter 2009-03-26 16:50:21 EDT
This bug should have been marked as closed per SSkracic: UPDATE (Seb 2008-06-19): could not reproduce it, so marked as CLOSED/CURRENT_RELEASE.

Note You need to log in before you can comment on or make changes to this bug.