Bug 43376 - Search with * wrong!
Summary: Search with * wrong!
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: vim
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-04 14:29 UTC by Sammy
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2002-01-24 23:04:25 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2002:017 normal SHIPPED_LIVE Updated vim packages are available 2002-01-22 05:00:00 UTC

Description Sammy 2001-06-04 14:29:09 UTC
Description of Problem:

In the latest version from rawhide, if one searches for a string with an *
character all previous characters are also searched...e.g. if you search
for XF* to find all oocurances of XFree86, all X's are also higlighted and
searched for! The search seems to be for string upto the * and also the
string upto the star minus the last character .e.g searching for vim* also
finds all vi's

How Reproducible:

Always

Steps to Reproduce:
1. rpm -q -a > out
2. vi out
3. /XF*

Actual Results:


Expected Results:

What it used to do before.

Additional Information:

Comment 1 Bernhard Rosenkraenzer 2002-01-28 22:38:26 UTC
Fixed in 6.0-7.13 (errata just released)

Comment 2 keithu@parl.clemson.edu 2002-01-30 17:25:59 UTC
NO!!!  vi searches with regular expressions.  (use vi under Solaris, for
example).  If you search with "/XF*", you are supposed to get all occurences of
X, XF, XFF, XFFF, etc.  i.e. that * means "0 or more occurences of F".  If you
want to search for all occurences of "XF and then some string of characters",
you should search for "XF.*".  

I repeat, the behavior BEFORE this update was CORRECT.


Note You need to log in before you can comment on or make changes to this bug.