Bug 433801 - mount.ecryptfs fails to mount with "Disk quota exceeded"
mount.ecryptfs fails to mount with "Disk quota exceeded"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ecryptfs-utils (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-21 10:21 EST by Michal Nowak
Modified: 2013-03-18 12:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 05:48:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2008-02-21 10:21:00 EST
Description of problem:

dhcp-lab-198 sigsegv # mount -t ecryptfs crypt crypt/
Select key type to use for newly created files: 
 1) openssl
 2) passphrase
Selection: 2
Passphrase: 
Verify Passphrase: 
Attempting to mount with the following options:
Required mount option not provided: [ecryptfs_key_bytes=]
Invalid mount options; aborting. rc = [1]
Error mounting eCryptfs; rc = [-1]; strerr = [Operation not permitted]. Check
your system logs; visit <http://ecryptfs.sourceforge.net/ecryptfs-faq.html>.


And in log:

Feb 21 16:05:41 dhcp-lab-198 mount.ecryptfs: Error adding key with sig
[7a1719eb53966dd1]; rc = [-1] Disk quota exceeded" 


Version-Release number of selected component (if applicable):

ecryptfs-utils-40-1.el5

Linux dhcp-lab-198.englab.brq.redhat.com 2.6.18-81.el5xen #1 SMP Tue Feb 12
21:57:38 EST 2008 i686 i686 i386 GNU/Linux

How reproducible: after day successful ecryptfs mounting

Steps to Reproduce:
1. mount -t ecryptfs crypt crypt/
  
Actual results:

dir not mounted

Expected results:

dir mounted

Additional info:

unloading and loading ecryptfs module fixed it, maybe it's not a problem in
ecryptfs but kernel keyring.
Comment 1 Michal Nowak 2008-02-21 10:23:24 EST
Note that I have no qouta restriction set nor being on low disk space.
Comment 2 Michal Nowak 2008-02-21 10:44:50 EST
Hmmm, maybe is possible that I inserted bad passphrase only but the err msg is
still confusing me.
Comment 3 Phil Knirsch 2008-04-28 08:45:25 EDT
Proposing for RHEL-5.3, waiting with final ACK on developer review.

Read ya, Phil 
Comment 4 Phil Knirsch 2008-05-14 10:00:11 EDT
Proposing bug for RHEL-5.3 FasTrack.

Read ya, Phil
Comment 5 RHEL Product and Program Management 2008-06-09 17:58:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Phil Knirsch 2008-06-13 09:22:32 EDT
This bug needs a review from the component owner before granting Devel ACK.

Thanks,

Read ya, Phil
Comment 8 Phil Knirsch 2008-06-27 11:59:31 EDT
Should be simple to fix the error message. Granting Devel ACK.

Read ya, Phil
Comment 11 Karsten Hopp 2008-08-11 09:07:26 EDT
Eric, any idea about this one ? The last sentence of the description hints at the kernel being the culprit. Do you know if there were any changes in this area ?
Comment 12 Eric Sandeen 2008-08-11 12:38:46 EDT
This is a bit odd; the message comes right after a call to add_key(), which I think does not ever exercise any ecryptfs code at all:

ADD_KEY(2)                Linux Key Management Calls                ADD_KEY(2)

NAME
       add_key - Add a key to the kernel’s key management facility

SYNOPSIS
       #include <keyutils.h>

the fact that it was in the syslog is only because mount.ecryptfs logs it there; it's not a kernel message.

Also, EDQUOT is a valid return for add_key:

       EDQUOT The key quota for this user would be exceeded by creating this key or linking it to the keyring.

... honestly I'm not sure why unloading & reloading the ecryptfs module would fix this, but I don't claim to be an expert on key management...
Comment 13 Karsten Hopp 2008-08-14 08:40:58 EDT
Do you have a reproducable testcase or are you still able to reproduce this on your system with ecryptfs-utils-56 ?
Comment 15 Michal Nowak 2008-10-09 04:29:19 EDT
At them moment this is not reproducible for me. I guess we can close this as notabug and eventually re-open later.
Comment 16 Phil Knirsch 2008-10-09 05:48:17 EDT
Closing this bug than as per comment #15.

Please feel free to reopen if it reoccurs.

Thanks & Regards,

Phil
Comment 17 Priti Jain 2013-03-18 12:24:40 EDT
Hi Phil,

I a facing this error regularly.

I am getting the same error after it called add_key() and error is it showing 

error : Quota exceeded.

that's why it is Unable to add token to keyring.

Please let me know what can be the workaround for this.


Thanks
Priti

Note You need to log in before you can comment on or make changes to this bug.