Bug 433810 - system-config-network met exception error
system-config-network met exception error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dbus-glib (Show other bugs)
8
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-21 10:53 EST by lxy0451
Modified: 2013-03-05 22:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 19:53:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump file (6.37 KB, text/plain)
2008-02-21 10:53 EST, lxy0451
no flags Details

  None (edit)
Description lxy0451 2008-02-21 10:53:17 EST
Description of problem:
system-config-network:<module>:ImportError: /usr/lib64/libdbus-glib-1.so.2:
undefined symbol: g_assertion_message_expr

Version-Release number of selected component (if applicable):
Version: 1.4.3



Steps to Reproduce:
1. type  system-config-network  in terminal window
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 lxy0451 2008-02-21 10:53:17 EST
Created attachment 295522 [details]
dump file
Comment 2 Harald Hoyer 2008-02-21 11:22:03 EST
$ rpm -qf /usr/lib64/libdbus-glib-1.so.2
dbus-glib-0.73-5.fc8
Comment 4 lxy0451 2008-02-22 06:40:33 EST
thank you for response 

output :

[root@localhost ~]# rpm  -qf  /usr/lib64/libdbus-glib-1.so.2  dbus-glib-0.73-
5.fc8
dbus-glib-0.74-3.fc9
error: file /root/dbus-glib-0.73-5.fc8: No such file or directory

next step please?
Comment 5 Jiri Moskovcak 2008-02-22 06:51:09 EST
You have dbus-glib package from F9 you need to downgrade this package or 
upgrade the glib package.
Comment 6 Matthias Clasen 2008-02-22 19:53:23 EST
A fresh, fully updated F8 installation does not exhibit this problem.
So I am going to assume that this is some problem with mixed F8/F9 packages.
Comment 7 lxy0451 2008-03-02 05:33:51 EST
when i tried to uninstall that fc9 package , i typed :
#  rpm  -e  dbus-glib-0.74-3.fc9
output is;

error:"dbus-glib-0.74-3.fc9" specifies multiple packages



Comment 8 lxy0451 2008-03-02 05:40:22 EST
then i tried to use yum command

yum remove  dbus-glib-0.74-3.fc9

it is erasing 223 packages!
Comment 9 lxy0451 2008-03-02 05:43:29 EST
then i tried to use yum command

yum remove  dbus-glib-0.74-3.fc9

it is erasing 223 packages!
Comment 10 lxy0451 2008-03-02 05:53:19 EST
(In reply to comment #5)
> You have dbus-glib package from F9 you need to downgrade this package or 
> upgrade the glib package.

after i type yum uninstall dbus-glib...  , 223 packages are erased , 
many functions have dispearred ,for example , terminal window ,
system-config-network menu items...., help me  please!!

Note You need to log in before you can comment on or make changes to this bug.