This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 433831 - Satellite installs broken again: global name 'FedoraImageStore' is not defined
Satellite installs broken again: global name 'FedoraImageStore' is not defined
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-21 11:52 EST by Cole Robinson
Modified: 2009-12-14 16:18 EST (History)
1 user (show)

See Also:
Fixed In Version: RHEA-2008-0371
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:45:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Update satellite patch to match current internal api (1.54 KB, patch)
2008-02-21 11:54 EST, Cole Robinson
no flags Details | Diff

  None (edit)
Description Cole Robinson 2008-02-21 11:52:44 EST
Trying to install a PV guest using an invalid url in virt-install or
virt-manager throws doesn't fail cleanly. The error thrown is:

Unable to complete install 'exceptions.NameError global name 'FedoraImageStore'
is not defined
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 612, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 811, in
start_install
    self._prepare_install(meter)
  File "/usr/lib/python2.4/site-packages/virtinst/ParaVirtGuest.py", line 56, in
_prepare_install
    self._installer.prepare(guest = self, meter = meter)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 239,
in prepare
    self._prepare_kernel_and_initrd(guest, distro, meter)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 209,
in _prepare_kernel_and_initrd
    distro = distro)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 115,
in acquireKernel
    scratchdir=scratchdir)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 60, in
_checkRHDistro
    store = FedoraImageStore(baseuri, type, scratchdir)
NameError: global name 'FedoraImageStore' is not defined

This will cause satellite installs to fail as its the piece of code that jumps
ahead to try and probe the tree, since the base url doesn't resolve for a
satellite hosted tree. See bz 367051.
Comment 1 Cole Robinson 2008-02-21 11:54:06 EST
Created attachment 295539 [details]
Update satellite patch to match current internal api
Comment 2 Cole Robinson 2008-02-21 12:04:32 EST
As far as testing this, prior to the fix entering any wrong url for a pv install
(ex. http:/iprobablydontexist.com/tree) will throw the above error. After the
patch, there will be an error saying roughly "Couldn't access url <blah>".
Comment 3 RHEL Product and Program Management 2008-02-21 12:07:55 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Daniel Berrange 2008-02-21 12:10:56 EST
This is a regression from 5.1 so we MUST fix.
Comment 6 Cole Robinson 2008-02-25 17:34:18 EST
This has been committed and built:

$ brew latest-pkg dist-5E-qu-candidate python-virtinst
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
python-virtinst-0.300.2-5.el5             dist-5E-qu-candidate  crobinso
Comment 9 errata-xmlrpc 2008-05-21 12:45:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0371.html

Note You need to log in before you can comment on or make changes to this bug.