This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 433882 - Potential upgrade F8 -> F9 issue with screen %pre script
Potential upgrade F8 -> F9 issue with screen %pre script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: screen (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-21 17:28 EST by Andrew Farris
Modified: 2008-02-26 12:21 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 12:21:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Farris 2008-02-21 17:28:04 EST
Description of problem:
Potential upgrade path issue with screen %pre script.  When updating screen from
the fc8 version (was the previous rawhide latest) to the fc9 build, the %pre
script generates an error about groupadd permissions.

Removing screen and reinstalling did not produce the problem.  Is this something
that needs addressed?

Version-Release number of selected component (if applicable):
screen-4.0.3-8.fc8
screen-4.0.3-9.fc9

Additional info:

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 screen                  x86_64     4.0.3-9.fc9      development       584 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total size: 584 k
Downloading Packages:
using local copy of screen-4.0.3-9.fc9.x86_64
Running rpm_check_debug
Member: screen.x86_64 0-4.0.3-9.fc9 - u
Adding Package screen-4.0.3-9.fc9.x86_64 in mode u
Member: screen.x86_64 0-4.0.3-8.fc8 - None
Running Transaction Test
Member: screen.x86_64 0-4.0.3-9.fc9 - u
Adding Package screen-4.0.3-9.fc9.x86_64 in mode u
Member: screen.x86_64 0-4.0.3-8.fc8 - None
Finished Transaction Test
Transaction Test Succeeded
Member: screen.x86_64 0-4.0.3-9.fc9 - u
Adding Package screen-4.0.3-9.fc9.x86_64 in mode u
Member: screen.x86_64 0-4.0.3-8.fc8 - None
Running Transaction
/var/tmp/rpm-tmp.98616: line 1: /usr/sbin/groupadd: Permission denied
error: %pre(screen-4.0.3-9.fc9.x86_64) scriptlet failed, exit status 126
error:   install: %pre scriptlet failed (2), skipping screen-4.0.3-9.fc9

Updated: screen.x86_64 0:4.0.3-9.fc9
Complete!

07:06:16  |root.durthangnix:2| |27 files:828K@yum| |0 jobs|
 - rpm -e screen

07:06:25  |root.durthangnix:2| |27 files:828K@yum| |0 jobs|
 - yum install screen
Loaded plugins: basearchonly, fastestmirror, fedorakmod, priorities, security
Loading mirror speeds from cached hostfile
 * development: mirrors.usc.edu
 * livna-development: www.lordmorgul.net
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package screen.x86_64 0:4.0.3-9.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 screen                  x86_64     4.0.3-9.fc9      development       584 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total size: 584 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: screen                       ######################### [1/1] 

Installed: screen.x86_64 0:4.0.3-9.fc9
Complete!
Comment 1 Miroslav Lichvar 2008-02-26 12:21:31 EST
I couldn't reproduce the problem, seems to be working ok in current rawhide. But
in any case, the scriptlet shouldn't fail, fixed in screen-4.0.3-10.fc9.

Note You need to log in before you can comment on or make changes to this bug.