Bug 433937 - trace when running "service network restart"
trace when running "service network restart"
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
beta
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Arnaldo Carvalho de Melo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 04:14 EST by Graham Biswell
Modified: 2014-08-14 21:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-01 17:28:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Biswell 2008-02-22 04:14:36 EST
I changed the MTU's for a bond interface & associated network devices to support
jumbo frames. Ran "system network restart" & got the following traces. The same
command ran on 2 other identical systems with no problems.

Hardware is dl585 with e1000 NIC's.

kernel is 2.6.24-0.14.rc8 (x86_64).

Call Trace:
 [<ffffffff8043d7da>] fib_rules_event+0x4f/0x128
 [<ffffffff804a89fe>] notifier_call_chain+0x33/0x5b
 [<ffffffff802566dd>] __raw_notifier_call_chain+0x9/0xb
 [<ffffffff802566ee>] raw_notifier_call_chain+0xf/0x11
 [<ffffffff8042fabe>] call_netdevice_notifiers+0x16/0x18
 [<ffffffff8042fd09>] netdev_state_change+0x22/0x36
 [<ffffffff8043a5f5>] __linkwatch_run_queue+0x171/0x19e
 [<ffffffff8043a64c>] linkwatch_event+0x2a/0x31
 [<ffffffff8024e7ef>] run_workqueue+0x108/0x1d8
 [<ffffffff8043a622>] linkwatch_event+0x0/0x31
 [<ffffffff8024f450>] worker_thread+0x0/0xea
 [<ffffffff8024f52f>] worker_thread+0xdf/0xea
 [<ffffffff802524bb>] autoremove_wake_function+0x0/0x38
 [<ffffffff80252395>] kthread+0x49/0x78
 [<ffffffff8020d068>] child_rip+0xa/0x12
 [<ffffffff8025234c>] kthread+0x0/0x78
 [<ffffffff8020d05e>] child_rip+0x0/0x12

RTNL: assertion failed at net/ipv4/devinet.c (1054)
Pid: 107, comm: events/0 Not tainted 2.6.24-0.14.rc8.el5rt #1

Call Trace:
 [<ffffffff8047cb79>] inetdev_event+0x5c/0x46b
 [<ffffffff8027daa9>] __rcu_read_unlock+0x5a/0x5c
 [<ffffffff804a89fe>] notifier_call_chain+0x33/0x5b
 [<ffffffff802566dd>] __raw_notifier_call_chain+0x9/0xb
 [<ffffffff802566ee>] raw_notifier_call_chain+0xf/0x11
 [<ffffffff8042fabe>] call_netdevice_notifiers+0x16/0x18
 [<ffffffff8042fd09>] netdev_state_change+0x22/0x36
 [<ffffffff8043a5f5>] __linkwatch_run_queue+0x171/0x19e
 [<ffffffff8043a64c>] linkwatch_event+0x2a/0x31
 [<ffffffff8024e7ef>] run_workqueue+0x108/0x1d8
 [<ffffffff8043a622>] linkwatch_event+0x0/0x31
 [<ffffffff8024f450>] worker_thread+0x0/0xea
 [<ffffffff8024f52f>] worker_thread+0xdf/0xea
 [<ffffffff802524bb>] autoremove_wake_function+0x0/0x38
 [<ffffffff80252395>] kthread+0x49/0x78
 [<ffffffff8020d068>] child_rip+0xa/0x12
 [<ffffffff8025234c>] kthread+0x0/0x78
 [<ffffffff8020d05e>] child_rip+0x0/0x12
Comment 1 Clark Williams 2008-03-11 16:00:49 EDT
Graham,

Have you tried this on 2.6.24.3-rt3 (which is currently only available in brew)?

Clark
Comment 2 Clark Williams 2008-04-23 17:25:59 EDT
Arnaldo,

Have you seen this with bonding on the latest kernels?

Clark
Comment 3 Arnaldo Carvalho de Melo 2008-05-06 14:12:33 EDT
I had only one network setup with bonding, on Shak's machines, will try to setup
it with rhelrt2 and 5.
Comment 4 Arnaldo Carvalho de Melo 2008-06-12 14:28:15 EDT
Tested now with just one bonding slave on rhel-rt2/5, changing the MTU of the
slave and of bond0 back and forth from/to 1500/9000, directly with ifconfig and
thru 'service network reload', no problem at all with recent kernels.

Was this observed with recent kernels? Perhaps this is a driver problem?
rhelrt-2 has a bnx2 card and rhelrt-5 has a e1000 card.
Comment 5 Arnaldo Carvalho de Melo 2008-06-12 16:14:50 EDT
Tried now with:

[root@rhelrt-2 network-scripts]# uname -r
2.6.24-0.10.rc8.el5rt

Couldn't reproduce with this kernel either.

Note You need to log in before you can comment on or make changes to this bug.