Bug 433950 - conga hangs when probing storage on xen cluster nodes.
conga hangs when probing storage on xen cluster nodes.
Status: CLOSED DUPLICATE of bug 238935
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.1
i386 Linux
high Severity medium
: rc
: ---
Assigned To: Jim Parsons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 05:27 EST by Stuart Sears
Modified: 2009-04-16 18:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-24 21:41:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Sears 2008-02-22 05:27:14 EST
Description of problem:
conga hangs probing storage on xen cluster nodes.

Version-Release number of selected component (if applicable):
0.10.0-6.el5

How reproducible:
every time!

Steps to Reproduce:
1. create a xen cluster, where the nodes have a primary disk called xvda
2. install conga (and the appropriate additional packages)
3. use the luci interface to probe storage on one of the cluster nodes.
  
Actual results:
a large number of parted processes on the cluster node, which hang while trying
to probe the storage devices on that node.

Expected results:
luci displays the storage devices attached to that particular node.

Additional info:
This seems to be related to the device names used by the nodes. It may actually
be a parted problem (or the way we use parted for this). If the disks used by
the xen machines are renamed to 'hd*' (or, I assume sd* - didn't test this) the
storage probe returns immediately and works properly.
Comment 1 Stuart Sears 2008-02-22 05:33:02 EST
After some more searching, it may well be #366971 causing this. Seems likely.
Comment 2 Ryan McCabe 2008-03-24 21:41:49 EDT
A bug in parted is causing the hang, but conga should handle that kind of
behavior better. Duping into the RFE to support multiple concurrent tasks on a
busy entity, if possible.

*** This bug has been marked as a duplicate of 238935 ***

Note You need to log in before you can comment on or make changes to this bug.