Bug 4342 - eth0 and ppp dialup linuxconf misconfogured route
eth0 and ppp dialup linuxconf misconfogured route
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-03 20:07 EDT by okosamastarr
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-04 09:39:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description okosamastarr 1999-08-03 20:07:00 EDT
if U are configuring an eth0 device and make an
ppp dialup to an ISP you are unable to get
queries from the internet, because of the wrong route !

SuSE 6.1 YaST can handle this propperly !

Have a look at the knowledge base at www.SuSE.de search
keyword DUMMY !

there should be a dummy device

e.g. 192.168.0.99 Bcast:192.168.0.255 mask:255.255.255
eth0
192.168.0.99 bcast: 192.168.0.255 mask:255.255.255.0
lo
127.0.0.1 mask 255.0.0.0

linuxconf permitts a netmask 255.255.255.255 for dummy0

and due this point i have not figured out how 2 set the
fuckin' route to:
myhost.mydomnin... 255.255.255.255 dummy0
192.168.0.0 eth0
loopback 255.0.0.0 lo

U can manage this only by editting /etc/sysconfig/network...
manually...

Do you have a solution 4 setting up an eth0 device *AND*
gettin propperly connected via dynamic ppp0 ?

I can't set a static route - the people at SuSE managed it !

I know, it's not really a "bug" rather a support question,.
but linuxconf should be able to handle this propperly...

YaST can do this !

bye...
Comment 1 Michael K. Johnson 1999-08-04 09:33:59 EDT
Choose the "set default route" option for ppp.  My own home
system had two ethernets and a ppp until recently, and it
worked fine this way.  If that doesn't meet your need, you
need to explain more precisely what you are trying to do.  As
far as I can tell from your explanation, there is nothing
different in what you are trying to do from what I know works
correctly if you simply have pppd set the default route, and
that option is given to you from within linuxconf.  There is
no need to waste memory with the dummy device to do this.
Comment 2 Michael K. Johnson 1999-08-04 09:38:59 EDT
Scratch that, tested wrong, fixing now...
Comment 3 Michael K. Johnson 1999-08-04 09:39:59 EDT
Oops, typed previous reopen in wrong window...
This bug really is closed, sorry for the confusion...

Note You need to log in before you can comment on or make changes to this bug.