Bug 434565 - TB40619167 isdnhardware.py:207:setup:AttributeError: 'module' object has no attribute 'card'
TB40619167 isdnhardware.py:207:setup:AttributeError: 'module' object has no a...
Status: CLOSED DUPLICATE of bug 416821
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 14:48 EST by Mark Polo
Modified: 2008-03-31 06:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 06:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Polo 2008-02-22 14:48:15 EST
Description of problem:


Version-Release number of selected component (if applicable):
system-config-network-1.4.7-1.fc8


How reproducible:
Enter the GUI and choose Edit on an existing ISDN connection or Add an ISDN
connection.

Steps to Reproduce:
1. Click on Edit
2. Input the necessary information
3. Click save
  
Actual results:
Component: system-config-network
Version: 1.4.7
Summary: TB40619167 isdnhardware.py:207:setup:AttributeError: 'module' object
has no attribute 'card'

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
793, in on_editButton_clicked
    self.editButtonFunc[self.active_page](button)
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
1615, in on_hardwareEditButton_clicked
    if self.showHardwareDialog(hw) == gtk.RESPONSE_OK:
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
1625, in showHardwareDialog
    dl = hw.getDialog()
  File "/usr/share/system-config-network/netconfpkg/plugins/NCHWIsdn.py", line
34, in getDialog
    return _hwIsdnDialog(self).xml.get_widget("Dialog")
  File "/usr/share/system-config-network/netconfpkg/gui/isdnhardware.py", line
56, in __init__
    self.setup()
  File "/usr/share/system-config-network/netconfpkg/gui/isdnhardware.py", line
207, in setup
    cardlist = NCisdnhardware.card.keys()
AttributeError: 'module' object has no attribute 'card'

Local variables in innermost frame:
self: <netconfpkg.gui.isdnhardware.isdnHardwareDialog instance at 0x10fcf80>

Expected results:
Not crashing

Additional info:
Comment 1 Mark Polo 2008-03-17 06:56:04 EDT
This problem still persists. (And now, with the kernel bug with my ISDN card
fixed, I'd really like to get the card working again...).

Do you need more information to be able to process this? Thank you.
Comment 2 Harald Hoyer 2008-03-31 06:44:28 EDT

*** This bug has been marked as a duplicate of 416821 ***

Note You need to log in before you can comment on or make changes to this bug.