Bug 434604 - yum errors out with rpm_check_debug vs. depsolve on sane-backends-libs-gphoto2
yum errors out with rpm_check_debug vs. depsolve on sane-backends-libs-gphoto2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 436657
  Show dependency treegraph
 
Reported: 2008-02-22 23:03 EST by Charles R. Anderson
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-08 19:14:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of yum -v -d10 update (24.96 KB, text/plain)
2008-02-22 23:10 EST, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2008-02-22 23:03:21 EST
Description of problem:

"yum update" fails on sane-backends-libs-gphoto2 with "ERROR with
rpm_check_debug vs depsolve".

Version-Release number of selected component (if applicable):
yum-3.2.11-1.fc9.noarch

How reproducible:
always

Steps to Reproduce:
1. yum update

Actual results:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package sane-backends-libs-gphoto2 needs sane-backends-libs =
1.0.19-5.fc9, this is not available.
Package sane-backends-libs-gphoto2 needs sane-backends-libs =
1.0.19-5.fc9, this is not available.
Complete!


Expected results:

Either a yum dependency error before it gets to the "rpm_check_debug vs.
depsolve" phase, or properly updated packages.

Additional info:

$ rpm -qa sane\*
sane-backends-libs-1.0.19-5.fc9.x86_64
sane-backends-1.0.19-5.fc9.x86_64
sane-backends-libs-1.0.19-5.fc9.i386
sane-backends-libs-gphoto2-1.0.19-5.fc9.x86_64
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386


$ rpm -Va sane\*
prelink: /usr/lib64/libsane.so.1.0.19: at least one of file's dependencies has
changed since prelinking
S.?.....    /usr/lib64/libsane.so.1.0.19
S.5....T  c /etc/sane.d/dll.conf
prelink: /usr/bin/sane-find-scanner: at least one of file's dependencies has
changed since prelinking
S.?.....    /usr/bin/sane-find-scanner
prelink: /usr/bin/scanimage: at least one of file's dependencies has changed
since prelinking
S.?.....    /usr/bin/scanimage
prelink: /usr/sbin/saned: at least one of file's dependencies has changed since
prelinking
S.?.....    /usr/sbin/saned


$ yum list sane\*
Loaded plugins: presto
Setting up and reading Presto delta metadata
No Presto metadata available for livna-development
No Presto metadata available for adobe-linux-i386
No Presto metadata available for development
Installed Packages
sane-backends.x86_64                     1.0.19-5.fc9           installed       
sane-backends-libs.x86_64                1.0.19-5.fc9           installed       
sane-backends-libs.i386                  1.0.19-5.fc9           installed       
sane-backends-libs-gphoto2.x86_64        1.0.19-5.fc9           installed       
sane-backends-libs-gphoto2.i386          1.0.19-5.fc9           installed       
Available Packages
sane-backends.x86_64                     1.0.19-6.fc9           development     
sane-backends-devel.i386                 1.0.19-6.fc9           development     
sane-backends-devel.x86_64               1.0.19-6.fc9           development     
sane-backends-libs.x86_64                1.0.19-6.fc9           development     
sane-backends-libs.i386                  1.0.19-6.fc9           development     
sane-backends-libs-gphoto2.x86_64        1.0.19-6.fc9           development     
sane-frontends.x86_64                    1.0.14-4.fc9           development
Comment 1 Charles R. Anderson 2008-02-22 23:10:39 EST
Created attachment 295696 [details]
output of yum -v -d10 update
Comment 2 Charles R. Anderson 2008-03-08 15:12:52 EST
Well, I guess this is an improvement.  Now I get a proper dependency error from
yum rather than the late "rpm_chech_debug vs. depsolve" error.  It looks like
the issue is that there is a missing i386 version of the package
sane-backends-libs-gphoto2.

If you look at the output above, I have this installed:

sane-backends-libs-gphoto2-1.0.19-5.fc9.i386

But yum list doesn't show an available 1.0.19-6.fc9.i386 version.

The master FTP site is missing the .i386 version in the x86_64 repo.


# yum  update
Loaded plugins: presto
Setting up and reading Presto delta metadata
No Presto metadata available for livna-development
No Presto metadata available for adobe-linux-i386
No Presto metadata available for development
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package sane-backends-libs.i386 0:1.0.19-6.fc9 set to be updated
---> Package kdelibs-common.x86_64 6:4.0.2-8.fc9 set to be updated
---> Package xorg-x11-server-common.x86_64 0:1.4.99.901-1.20080307.fc9 set to be
updated
---> Package python.x86_64 0:2.5.1-23.fc9 set to be updated
---> Package libstdc++-devel.x86_64 0:4.3.0-2 set to be updated
---> Package ncurses-libs.i386 0:5.6-16.20080301.fc9 set to be updated
---> Package python-libs.x86_64 0:2.5.1-23.fc9 set to be updated
---> Package ncurses-base.x86_64 0:5.6-16.20080301.fc9 set to be updated
---> Package libgcj.x86_64 0:4.3.0-2 set to be updated
---> Package libstdc++.x86_64 0:4.3.0-2 set to be updated
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
---> Package libmtp.x86_64 0:0.2.6.1-1.fc9 set to be updated
---> Package xorg-x11-drv-nv.x86_64 0:2.1.8-1.fc9 set to be updated
---> Package sane-backends-libs.x86_64 0:1.0.19-6.fc9 set to be updated
---> Package xorg-x11-drv-openchrome.x86_64 0:0.2.901-11.fc9 set to be updated
---> Package python-libs.i386 0:2.5.1-23.fc9 set to be updated
---> Package shadow-utils.x86_64 2:4.1.0-5.fc9 set to be updated
---> Package python-fedora.noarch 0:0.2.99.2-2.fc9 set to be updated
---> Package sysvinit-tools.x86_64 0:2.86-23 set to be updated
---> Package libgcc.i386 0:4.3.0-2 set to be updated
---> Package yum-utils.noarch 0:1.1.11-5.fc9 set to be updated
---> Package python-twisted-web.x86_64 0:0.7.0-3.fc9 set to be updated
---> Package samba-client.x86_64 0:3.2.0-1.pre2.6.fc9 set to be updated
---> Package libidn.i386 0:0.6.14-6 set to be updated
---> Package kdebase-runtime.x86_64 0:4.0.2-3.fc9 set to be updated
---> Package system-config-services.noarch 0:0.99.8-1.fc9 set to be updated
---> Package kdelibs.x86_64 6:4.0.2-8.fc9 set to be updated
---> Package gnash-plugin.x86_64 0:0.8.2-1.fc9 set to be updated
---> Package gcc-c++.x86_64 0:4.3.0-2 set to be updated
---> Package event-compat-sysv.noarch 0:0.3.9-9.fc9 set to be updated
--> Processing Dependency: libwbclient.so.0()(64bit) for package: libsmbclient
--> Processing Dependency: libwbclient.so.0()(64bit) for package: samba-common
--> Processing Dependency: libwbclient.so.0()(64bit) for package: samba-client
---> Package totem.x86_64 0:2.23.0-2.fc9 set to be updated
---> Package gnash.x86_64 0:0.8.2-1.fc9 set to be updated
---> Package libmudflap.x86_64 0:4.3.0-2 set to be updated
---> Package bluez-gnome.x86_64 0:0.24-1.fc9 set to be updated
---> Package libmtp.i386 0:0.2.6.1-1.fc9 set to be updated
---> Package python-twisted-core.x86_64 0:2.5.0-4.fc9 set to be updated
---> Package rsyslog.x86_64 0:3.12.1-1.fc9 set to be updated
---> Package cpp.x86_64 0:4.3.0-2 set to be updated
---> Package libidn.x86_64 0:0.6.14-6 set to be updated
---> Package ncurses.x86_64 0:5.6-16.20080301.fc9 set to be updated
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
---> Package libgomp.x86_64 0:4.3.0-2 set to be updated
---> Package gcc.x86_64 0:4.3.0-2 set to be updated
---> Package sane-backends-libs-gphoto2.x86_64 0:1.0.19-6.fc9 set to be updated
---> Package libtdb.x86_64 0:1.1.1-1.pre2.6.fc9 set to be updated
---> Package ncurses-libs.x86_64 0:5.6-16.20080301.fc9 set to be updated
---> Package totem-gstreamer.x86_64 0:2.23.0-2.fc9 set to be updated
---> Package libsmbclient.x86_64 0:3.2.0-1.pre2.6.fc9 set to be updated
---> Package java-1.7.0-icedtea-plugin.x86_64 0:1.7.0.0-0.29.b24.fc9 set to be
updated
---> Package gdm.x86_64 1:2.21.9-0.2008.02.29.3.fc9 set to be updated
---> Package samba-common.x86_64 0:3.2.0-1.pre2.6.fc9 set to be updated
---> Package xorg-x11-server-Xorg.x86_64 0:1.4.99.901-1.20080307.fc9 set to be
updated
---> Package libstdc++.i386 0:4.3.0-2 set to be updated
---> Package libtalloc.x86_64 0:1.2.0-1.pre2.6.fc9 set to be updated
---> Package sane-backends.x86_64 0:1.0.19-6.fc9 set to be updated
---> Package libgomp.i386 0:4.3.0-2 set to be updated
---> Package java-1.7.0-icedtea.x86_64 0:1.7.0.0-0.29.b24.fc9 set to be updated
---> Package libgnomeui.x86_64 0:2.21.93-1.fc9 set to be updated
---> Package gdm-user-switch-applet.x86_64 1:2.21.9-0.2008.02.29.3.fc9 set to be
updated
---> Package totem-mozplugin.x86_64 0:2.23.0-2.fc9 set to be updated
---> Package gtk-vnc.x86_64 0:0.3.4-1.fc9 set to be updated
---> Package man-pages.noarch 0:2.78-2.fc9 set to be updated
---> Package libgcj.i386 0:4.3.0-2 set to be updated
---> Package totem-xine.x86_64 0:2.23.0-2.fc9 set to be updated
---> Package libgcc.x86_64 0:4.3.0-2 set to be updated
---> Package libgnomeui.i386 0:2.21.93-1.fc9 set to be updated
--> Running transaction check
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
---> Package samba-winbind.x86_64 0:3.2.0-1.pre2.6.fc9 set to be updated
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
--> Finished Dependency Resolution
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: sane-backends-libs = 1.0.19-5.fc9 is needed by package
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 (installed)
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: sane-backends-libs = 1.0.19-5.fc9 is needed by package
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 (installed)
Error: Missing Dependency: sane-backends-libs = 1.0.19-5.fc9 is needed by
package sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 (installed)


Comment 3 Seth Vidal 2008-03-08 19:14:52 EST
yes and if you're using 3.2.12 from rawhide you can run:

yum --skip-broke update to get around the problem.

Comment 4 Charles R. Anderson 2008-03-09 12:38:37 EDT
yum-3.2.12-3.fc9.noarch

Skip-broken could not solve problems:

# yum --skip-broken update
Loaded plugins: presto
Setting up and reading Presto delta metadata
No Presto metadata available for livna-development
No Presto metadata available for adobe-linux-i386
No Presto metadata available for development
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package sane-backends-libs.x86_64 0:1.0.19-6.fc9 set to be updated
---> Package goffice.i386 0:0.6.2-1.fc9 set to be updated
---> Package python-fpconst.noarch 0:0.7.3-3.fc9 set to be updated
---> Package smolt.noarch 0:1.1.1.1-1.fc9 set to be updated
---> Package kernel-headers.x86_64 0:2.6.25-0.101.rc4.git3.fc9 set to be updated
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
---> Package kernel.x86_64 0:2.6.25-0.101.rc4.git3.fc9 set to be installed
---> Package gnumeric.i386 1:1.8.2-1.fc9 set to be updated
---> Package sane-backends.x86_64 0:1.0.19-6.fc9 set to be updated
---> Package smolt-firstboot.noarch 0:1.1.1.1-1.fc9 set to be updated
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
---> Package sane-backends-libs-gphoto2.x86_64 0:1.0.19-6.fc9 set to be updated
---> Package gtk-nodoka-engine.x86_64 0:0.6.99.1-1.fc9 set to be updated
---> Package kernel-devel.x86_64 0:2.6.25-0.101.rc4.git3.fc9 set to be installed
---> Package xorg-x11-drv-openchrome.x86_64 0:0.2.901-12.fc9 set to be updated
---> Package kernel-doc.noarch 0:2.6.25-0.101.rc4.git3.fc9 set to be updated
---> Package sane-backends-libs.i386 0:1.0.19-6.fc9 set to be updated
---> Package gnumeric.x86_64 1:1.8.2-1.fc9 set to be updated
---> Package alsa-plugins-pulseaudio.x86_64 0:1.0.16-1.fc9 set to be updated
---> Package goffice.x86_64 0:0.6.2-1.fc9 set to be updated
---> Package ClanLib.x86_64 0:0.8.0-11.fc9 set to be updated
---> Package wpa_supplicant.x86_64 1:0.6.3-4.fc9 set to be updated
---> Package xorg-x11-drv-evdev.x86_64 0:1.99.1-0.1.fc9 set to be updated
--> Finished Dependency Resolution
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: sane-backends-libs = 1.0.19-5.fc9 is needed by package
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 (installed)
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: sane-backends-libs = 1.0.19-5.fc9 is needed by package
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 (installed)
--> Running transaction check
---> Package kernel-devel.x86_64 0:2.6.25-0.65.rc2.git7.fc9 set to be erased
---> Package kernel.x86_64 0:2.6.25-0.65.rc2.git7.fc9 set to be erased
--> Processing Dependency: kernel-x86_64 = 2.6.25-0.65.rc2.git7.fc9 for package:
kmod-kqemu-2.6.25-0.65.rc2.git7.fc9
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
--> Running transaction check
---> Package kmod-kqemu-2.6.25-0.65.rc2.git7.fc9.x86_64 0:1.3.0-0.7.fc9 set to
be erased
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
--> Finished Dependency Resolution
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: sane-backends-libs = 1.0.19-5.fc9 is needed by package
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 (installed)
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: sane-backends-libs = 1.0.19-5.fc9 is needed by package
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 (installed)
--> Running transaction check
---> Package sane-backends-libs.i386 0:1.0.19-6.fc9 set to be updated
--> Processing Dependency: sane-backends-libs = 1.0.19-6.fc9 for package:
sane-backends-libs-gphoto2
--> Processing Dependency: sane-backends = 1.0.19-5.fc9 for package:
sane-backends-libs
---> Package sane-backends-libs.x86_64 0:1.0.19-6.fc9 set to be updated
--> Processing Dependency: sane-backends-libs = 1.0.19-6.fc9 for package:
sane-backends-libs-gphoto2
--> Processing Dependency: sane-backends = 1.0.19-5.fc9 for package:
sane-backends-libs
--> Finished Dependency Resolution
sane-backends-libs-1.0.19-5.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: sane-backends = 1.0.19-5.fc9 is needed by package
sane-backends-libs-1.0.19-5.fc9.x86_64 (installed)
sane-backends-libs-gphoto2-1.0.19-6.fc9.x86_64 from development has depsolving
problems
  --> Missing Dependency: sane-backends-libs = 1.0.19-6.fc9 is needed by package
sane-backends-libs-gphoto2-1.0.19-6.fc9.x86_64 (development)
sane-backends-libs-gphoto2-1.0.19-6.fc9.x86_64 from development has depsolving
problems
  --> Missing Dependency: sane-backends-libs = 1.0.19-6.fc9 is needed by package
sane-backends-libs-gphoto2-1.0.19-6.fc9.x86_64 (development)
sane-backends-libs-1.0.19-5.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: sane-backends = 1.0.19-5.fc9 is needed by package
sane-backends-libs-1.0.19-5.fc9.i386 (installed)
--> Running transaction check
---> Package sane-backends-libs-gphoto2.x86_64 0:1.0.19-6.fc9 set to be updated
---> Package sane-backends-libs.i386 0:1.0.19-6.fc9 set to be updated
--> Processing Dependency: sane-backends = 1.0.19-5.fc9 for package:
sane-backends-libs
---> Package sane-backends-libs.x86_64 0:1.0.19-6.fc9 set to be updated
--> Processing Dependency: sane-backends = 1.0.19-5.fc9 for package:
sane-backends-libs
--> Finished Dependency Resolution
sane-backends-libs-1.0.19-5.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: sane-backends = 1.0.19-5.fc9 is needed by package
sane-backends-libs-1.0.19-5.fc9.x86_64 (installed)
sane-backends-libs-1.0.19-5.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: sane-backends = 1.0.19-5.fc9 is needed by package
sane-backends-libs-1.0.19-5.fc9.i386 (installed)
--> Running transaction check
--> Processing Dependency: sane-backends = 1.0.19-5.fc9 for package:
sane-backends-libs
--> Processing Dependency: sane-backends = 1.0.19-5.fc9 for package:
sane-backends-libs
--> Finished Dependency Resolution
sane-backends-libs-1.0.19-5.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: sane-backends = 1.0.19-5.fc9 is needed by package
sane-backends-libs-1.0.19-5.fc9.x86_64 (installed)
sane-backends-libs-1.0.19-5.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: sane-backends = 1.0.19-5.fc9 is needed by package
sane-backends-libs-1.0.19-5.fc9.i386 (installed)
Skip-broken could not solve problems
Error: Missing Dependency: sane-backends-libs = 1.0.19-5.fc9 is needed by
package sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 (installed)



Note You need to log in before you can comment on or make changes to this bug.