Bug 434641 - libgee-devel conflicts with vala
libgee-devel conflicts with vala
Product: Fedora
Classification: Fedora
Component: libgee (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-02-23 14:25 EST by Robert Spanton
Modified: 2008-02-24 20:13 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-24 20:13:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert Spanton 2008-02-23 14:25:15 EST
Description of problem:
According to yum, libgee-devel contains /usr/share/vala/vapi/gee-1.0.vapi, which
is also provided by vala.  Therefore libgee-devel cannot be installed.

Version-Release number of selected component (if applicable):
libgee-devel: 0.1.1-2
vala: 0.1.5-5

Steps to Reproduce:
1. Run "yum install libgee-devel", then press 'y'.

Actual results:
yum aborts and says:
Transaction Check Error:
  file /usr/share/vala/vapi/gee-1.0.vapi from install of
libgee-devel-0.1.1-2.fc8.i386 conflicts with file from package vala-0.1.5-5.fc8.i386

Expected results:
Installation of libgee-devel without conflict.
Comment 1 Michel Alexandre Salim 2008-02-24 20:12:01 EST
Bizarre, vala in F-8 should be up to 0.1.6 by now, and should no longer ship
with gee-1.0.vapi. Will check.
Comment 2 Michel Alexandre Salim 2008-02-24 20:13:22 EST
Ah, the update was still in -testing -- it dropped into the second page on my
list of updates and since I'm now using Rawhide, I did not notice. Sorry! Grab
0.1.6 using 'yum --enable-repo=updates-testing update vala' for now; it should
hit -updates in a few more days.

Thanks for spotting!

Note You need to log in before you can comment on or make changes to this bug.