Bug 434654 - pulseaudio doesn't start in liboil-0.3.13-1.fc9
pulseaudio doesn't start in liboil-0.3.13-1.fc9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: liboil (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
hotissue
:
: 434651 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-23 19:38 EST by sangu
Modified: 2008-02-25 21:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 11:55:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-02-23 19:38:37 EST
Description of problem:
$ gdb /usr/bin/pulseaudio 
GNU gdb Red Hat Linux (6.7.1-14.fc9rh)
Copyright (C) 2007 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) r
[...]
New process 3774]
W: core-util.c: setpriority(): Permission denied
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
[New process 3774]

Program received signal SIGSEGV, Segmentation fault.
0x00247aec in splat_u16_ns_mmx_3 (dest=0x6edc, src=0x89b2c90, n=6)
    at copy.c:417
417	  asm volatile (
(gdb) bt
#0  0x00247aec in splat_u16_ns_mmx_3 (dest=0x6edc, src=0x89b2c90, n=6)
    at copy.c:417
#1  0x0023965d in _oil_test_marshal_function (func=0x247ab0, args=0xbf978b3c, 
    n_args=3, pointer_mask=14, prof=0x89b2544) at liboilmarshal.c:201
#2  0x0023b5da in oil_test_check_function (priv=0x89b1c98) at liboiltest.c:272
#3  0x0023886e in oil_fault_check_try (
    func=0x23b2e0 <oil_test_check_function>, priv=0x89b1c98)
    at liboilfault.c:131
#4  0x0023b790 in oil_test_check_impl (test=0x89b1c98, impl=0x288740)
    at liboiltest.c:359
#5  0x00238ed2 in oil_class_optimize (klass=0x28f200) at liboilfunction.c:383
#6  0x0023915b in oil_optimize_all () at liboilfunction.c:182
#7  0x0023931c in oil_init () at liboilfunction.c:141
#8  0x0804f39f in main (argc=1, argv=0xbf978eb4) at daemon/main.c:762
(gdb) 

Version-Release number of selected component (if applicable):
0.3.13-1.fc9

How reproducible:
always

Steps to Reproduce:
1. $ pulseaudio
2.
3.
  
Actual results:


Expected results:


Additional info:
rhythmbox doesnt' play.
play rhythmbox -> segmentation fault
$ rhythmbox

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstaudioresample.so
 ldd /usr/lib/gstreamer-0.10/libgstaudioresample.so 
[...]
	liboil-0.3.so.0 => /usr/lib/liboil-0.3.so.0 (0x00481000)
[...]
Comment 1 Jeffrey C. Ollie 2008-02-23 21:25:12 EST
*** Bug 434651 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Clasen 2008-02-23 21:39:02 EST
Filed upstream here:
http://bugs.freedesktop.org/show_bug.cgi?id=14643
Comment 3 Matthias Clasen 2008-02-25 11:55:42 EST
liboil-0.3.13-2.fc9 should work around the segfault for now. Let me know if it
doesn't work for you.
Comment 4 Gideon Mayhak 2008-02-25 21:47:26 EST
Things are back to normal with the 0.3.13-2 package.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.