Bug 434664 - Latest version of gallery2 (gallery2-2.2.4-2.fc7) will not install
Latest version of gallery2 (gallery2-2.2.4-2.fc7) will not install
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gallery2 (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: John Berninger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-23 23:18 EST by Timothy Murphy
Modified: 2008-03-22 16:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-22 16:53:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy Murphy 2008-02-23 23:18:48 EST
Description of problem: cannot install most recent version of gallery2


Version-Release number of selected component (if applicable): gallery2-2.2.4-2.fc7


How reproducible: 


Steps to Reproduce:
1. Install this version of gallery2 
2. Go to http://<server>/gallery2/install
3. At Step 2, I am told that 12 files have been changed,
and the installation fails.
  
Actual results:
There is a warning in Step 2 of the installation
that files have been modified;
and when clicking on "Go to my Gallery" after installation
(or upgrade) I get a blank page.


Expected results:
Should have gone to my existing gallery.


Additional info:
As far as I can see, some of the file sizes given in
/usr/share/gallery2/MANIFEST
do not match the actual sizes of the files, eg
in /usr/share/gallery2/MANIFEST
---------------------------------------
lib/tools/bin/extractClassXml.pl        1987079674      2958783943      1422    1484
---------------------------------------
and in /usr/share/gallery2/lib/tools/bin/
---------------------------------------
[root@alfred bin]# ls -ls
total 116
...
 4 -rwxr-xr-x 1 root root  1416 2007-12-29 14:06 extractClassXml.pl
---------------------------------------

I take it that this difference in file sizes is the cause of the failure.
Comment 1 Timothy Murphy 2008-02-24 14:47:13 EST
Apologies - while what I say above is true,
some file sizes are not reported correctly in MANIFEST -
this was not the cause of the failure.
On re-installing gallery2
(the latest fedora-development yum allows "yum reinstall"),
it worked "as advertised", though I still got the warning
about modified files.

Perhaps the suggestion that this is a likely cause of failure -
in fact the first cause suggested - should be altered,
since it does not seem to matter if MANIFEST reports wrongly.
Comment 2 John Berninger 2008-03-22 16:53:28 EDT
New package in testing should resolve this issue.

Note You need to log in before you can comment on or make changes to this bug.