Bug 434672 - cannot create xen guest('libvirt.libvirtError virDomainCreateLinux() failed)
cannot create xen guest('libvirt.libvirtError virDomainCreateLinux() failed)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-24 01:27 EST by Jong Bae KO
Modified: 2009-12-14 16:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 13:09:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jong Bae KO 2008-02-24 01:27:13 EST
Description of problem:
when xen guest is started, the host is rebooted.

Version-Release number of selected component (if applicable):
[root@merlion ~]# uname -r
2.6.18-53.1.13.el5xen
[root@merlion ~]# rpm -qa | grep xen
xen-libs-3.0.3-41.el5
xen-3.0.3-41.el5
kernel-xen-2.6.18-8.1.15.el5
kmod-gnbd-xen-0.1.3-4.2.6.18_8.1.15.el5
kernel-xen-2.6.18-53.1.13.el5
kmod-gnbd-xen-0.1.4-12.el5
kmod-gfs-xen-0.1.16-6.2.6.18_8.1.15.el5
kernel-xen-devel-2.6.18-53.1.13.el5
kmod-gfs-xen-0.1.19-7.el5_1.1
kernel-xen-devel-2.6.18-8.1.15.el5


How reproducible:
always

Steps to Reproduce:
1. xen guest is started(running)
2. reboot the host
3. cannot create or start xen guest
  
Actual results:
Unable to complete install 'libvirt.libvirtError virDomainCreateLinux() failed
POST operation failed: (xend.err "Error creating domain: (28, 'No space left on
device, while writing /local/domain/0/backend/vkbd/3/0/frontend-id : 3')")
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 681, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 649, in
start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 666, in
_do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.4/site-packages/libvirt.py", line 503, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed POST operation failed: (xend.err
"Error creating domain: (28, 'No space left on device, while writing
/local/domain/0/backend/vkbd/3/0/frontend-id : 3')")
'


Expected results:


Additional info:
Comment 1 Chris Lalancette 2008-02-26 23:00:04 EST
Huh.  This one looks like you ran out of space on /var.  xenstore uses a tdb in
/var/lib/xenstored/ and it sounds like there was no space left to write into it.
 Can you check that this is the case?  If so, there isn't a lot we can do here.

Chris Lalancette
Comment 2 Bill Burns 2009-03-20 13:09:02 EDT
Closing due to lack of need info response for over a year. Please reopen if it was not an out of space issue and you can reproduce. Thanks.

Note You need to log in before you can comment on or make changes to this bug.