Bug 434688 - monsterz does not start
monsterz does not start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: monsterz (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ian Chapman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-24 09:00 EST by Felix Schwarz
Modified: 2008-02-28 16:44 EST (History)
0 users

See Also:
Fixed In Version: 0.7.1-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 16:39:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2008-02-24 09:00:29 EST
Description of problem:
$ monsterz 
/usr/share/monsterz/monsterz.py: could not open data from `/usr/share/monsterz'.
Traceback (most recent call last):
  File "/usr/share/monsterz/monsterz.py", line 1994, in <module>
    main()
  File "/usr/share/monsterz/monsterz.py", line 1983, in main
    data = Data(sharedir)
  File "/usr/share/monsterz/monsterz.py", line 321, in __init__
    semi_grayscale(self.shaded[i])
  File "/usr/share/monsterz/monsterz.py", line 111, in semi_grayscale
    p[:] = (val + r) / 2, (val + g) / 2, (val + b) / 2
ValueError: matrices are not aligned for copy


Version-Release number of selected component (if applicable):
$ rpm -q monsterz
monsterz-0.7.1-1.fc8

How reproducible:
always

Steps to Reproduce:
1. Open a shell
2. enter "monsterz"
3. a new window opens for ~ 1/10 sec but disappears almost immediately.
  
Actual results:
Game does not start / shows the traceback above

Expected results:
Game should start
Comment 1 Ian Chapman 2008-02-25 13:27:21 EST
Are you running on a 64bit system?

Comment 2 Felix Schwarz 2008-02-25 14:43:47 EST
Yes.

$ uname -a
Linux ws2.schwarz.lokal 2.6.21.7-2.fc8xen #1 SMP Fri Feb 15 12:34:28 EST 2008
x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Ian Chapman 2008-02-26 09:34:38 EST
Could you try the following rpm, it should "fix" the issue and let me know if it
works:

http://dribble.org.uk/reviews/monsterz-0.7.1-3.fc8.drb.x86_64.rpm

Note: The patch is a bit of a quick fix. Monsterz on the right hand side are not
as grey as intended when you start a new game on 64bit archs. 
Comment 4 Felix Schwarz 2008-02-26 13:57:26 EST
Yes, "monsterz-0.7.1-3.fc8.drb.x86_64.rpm" starts/works correctly.
Comment 5 Ian Chapman 2008-02-26 14:36:09 EST
Thanks. An update will be pushed to the repositories shortly.
Comment 6 Fedora Update System 2008-02-26 17:44:43 EST
monsterz-0.7.1-3.fc7 has been submitted as an update for Fedora 7
Comment 7 Fedora Update System 2008-02-26 17:45:19 EST
monsterz-0.7.1-3.fc8 has been submitted as an update for Fedora 8
Comment 8 Fedora Update System 2008-02-28 16:39:16 EST
monsterz-0.7.1-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-02-28 16:44:11 EST
monsterz-0.7.1-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.