Bug 434796 - Thunderbird crashes if you close more than one compose window.
Thunderbird crashes if you close more than one compose window.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: thunderbird (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 10:52 EST by K. Scott Rowe
Modified: 2008-05-21 11:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0355
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:17:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace from reproducing the bug (8.26 KB, text/plain)
2008-02-25 17:23 EST, Matěj Cepl
no flags Details

  None (edit)
Description K. Scott Rowe 2008-02-25 10:52:49 EST
Description of problem:
Thunderbird crashes if you close more than one compose window.

Version-Release number of selected component (if applicable):
1.5.0.12-9.el5_1

How reproducible:
Every time for multiple users accross multiple machines.

Steps to Reproduce:
1. Start thunderbird.
2. Click on "Write" more than once to open more than one Compose window.
3. Close all Compose windows.
  
Actual results:
Thunderbird exits with a return code of 139.

Expected results:
Thunderbird not to exit.

Additional info:
I opened this issue with bug (432573).  It was then incorrectly merged with
bug (432702) and then both bugs were subsequently closed.  The problem remains
so I asked that the bug be re-opened, but got no response so I am filing 
a new bug.

jonathan auerbach from noaa.gov correctly states that this issue exists
with rhel4 as well as rhel5.
Comment 1 Matěj Cepl 2008-02-25 17:23:39 EST
Created attachment 295851 [details]
Backtrace from reproducing the bug

Yup, can reproduce pretty regularily with thunderbird-1.5.0.12-9.el5_1
(reproduced fourt times out of four attempts).
Comment 2 Andrew D. 2008-02-26 16:01:04 EST
I can confirm this as well on an i386 installation. I have also noticed that
sometimes, immediately after an e-mail is sent, a similar crash occurs (as soon
as the sending mail message window closes). The mail is copied to my send mail
folder and, I suspect, has been successfully sent. This is on
thunderbird-1.5.0.12-9.el5
Comment 3 Andrew D. 2008-02-26 16:41:32 EST
 
Just an additional note that might help isolate the problem. The latest
Thunderbird 2.0.0.9 (20071031) from Mozilla doesn't seem to suffer from this
issue. However, on my system I am running:

gtk2-2.10.13-1.fc6
gtk2-devel-2.10.13-1.fc6
gtk2-engines-2.8.0-3.el5
(switching to the 2.10.13-1.fc6 ones fixed a crash issue in firefox (bug 430140))
Comment 4 Matěj Cepl 2008-02-29 10:58:25 EST
Cannot reproduce anymore with upgaded packages to the latest production RHN
updates + these:

nspr-4.7.0.99.1-1.el5.i386.rpm
nss-3.11.99.4-1.el5.i386.rpm
nss-debuginfo-3.11.99.4-1.el5.i386.rpm
nss-tools-3.11.99.4-1.el5.i386.rpm
thunderbird-2.0.0.12-1.el5.i386.rpm
thunderbird-debuginfo-2.0.0.12-1.el5.i386.rpm
Comment 5 RHEL Product and Program Management 2008-02-29 11:08:13 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 errata-xmlrpc 2008-05-21 11:17:01 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0355.html

Note You need to log in before you can comment on or make changes to this bug.