Bug 434858 - Kerberos double logging
Summary: Kerberos double logging
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: krb5
Version: 5.1
Hardware: All
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On: 231147
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-25 21:04 UTC by Nalin Dahyabhai
Modified: 2009-01-20 22:10 UTC (History)
3 users (show)

Fixed In Version: 1.6.1-28.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 22:10:28 UTC


Attachments (Terms of Use)
patch to avoid setting the default config path to "/etc/krb5.conf:/etc/krb5.conf" (677 bytes, patch)
2008-02-25 21:04 UTC, Nalin Dahyabhai
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0234 normal SHIPPED_LIVE krb5 bug fix update 2009-01-20 16:06:36 UTC

Description Nalin Dahyabhai 2008-02-25 21:04:39 UTC
+++ This bug was initially created as a clone of Bug #231147 +++

Description of problem:

The KDC (krb5kdc), kadmin daemon (kadmind), and libraries create duplicate log
entries when using /etc/krb5.conf as a configuration source. Each logged event
is recorded twice.

Steps to Reproduce:
1. Install krb5-server
2. make sure /etc/krb5.conf contains a logging stanza that looks something like:

[logging]
 default = FILE:/var/log/krb5libs.log
 kdc = FILE:/var/log/krb5kdc.log
 admin_server = FILE:/var/log/kadmind.log

3. Start the KDC: 'service krb5kdc start'

Actual results:
/var/log/krb5kdc.log will show double entries, i.e. each line is duplicated. e.g

Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): setting up network...
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): setting up network...
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): skipping unrecognized
local address family 17
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): skipping unrecognized
local address family 17
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): listening on fd 7: udp
192.168.1.50.750
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): listening on fd 7: udp
192.168.1.50.750

... and so on.

Expected results:

A single line for each entry, like so:

Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): setting up network...
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): skipping unrecognized
local address family 17
Feb 24 17:44:47 host.name.hidden krb5kdc[26796](info): listening on fd 7: udp
192.168.1.50.750


Additional info:

After some investigation in the MIT krb5-bugs mailing list, it appears that is
is due to passing certain configure options to the package (probably
--sysconfdir=/etc is to blame). A temporary solution is to add the line

export KRB5_CONFIG=/etc/krb5.conf

to /etc/sysconfig/krb5kdc and /etc/sysconfig/kadmin

The discussion that helped me figure this out:
http://mailman.mit.edu/pipermail/krb5-bugs/2005-December/thread.html#4134

-Basil.

-- Additional comment from nalin@redhat.com on 2008-02-25 15:56 EST --
Fixing in 1.6.3-8.

Comment 1 Nalin Dahyabhai 2008-02-25 21:04:39 UTC
Created attachment 295841 [details]
patch to avoid setting the default config path to "/etc/krb5.conf:/etc/krb5.conf"

Comment 2 RHEL Product and Program Management 2008-06-02 20:17:05 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 6 errata-xmlrpc 2009-01-20 22:10:28 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0234.html


Note You need to log in before you can comment on or make changes to this bug.