Bug 434869 - installer crashes
installer crashes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
athlon Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 17:06 EST by Angelo Borsotti
Modified: 2008-02-27 03:34 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 03:34:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Angelo Borsotti 2008-02-25 17:06:18 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. download X_64 Fedora 8
2. burn a dvd
3. restart the computer
4. perform the media check
5. select US-English as language
6. select unused space to create partition on hard disc
7. continue
  
Actual results:

The media check is successful. However the installer displays a message
box telling that it has found a problem that is likely to be caused by
a bad media. After pressing the only one button (OK) in the message box,
the installer instead of quitting, proceeds.
After a while it displays another message, asking to report it to you.
This is clearly impossible since there is no way to copy and record it
(except perhaps making a photograph).
Again, pressing OK, the installer does not quit, but displays a black
screen with a clock in the midder and blocks. The only way to proceed is
to remove the dvd, turn off the computer and power it again.
Luckily, the installer created two primary partitions in the hard disc,
and did not damage the others.

Expected results:

Error messages MUST tell exactly what went wrong, and if that prevents
the installation to proceed, the installer MUST quit.
This installer looks like one that was used in the early days of
computing. Installation consists in creating a couple of partitions, copying
files and configuring some of them. In a computer that has already an
operating system running (e.g. Windows), this must be done as a plain, normal
operation of file creation.

Additional info:
Comment 1 Joel Andres Granados 2008-02-26 04:02:15 EST
Not much info to go on.  What was the second message?  I've seen some bugs that
include pictures and videos,  I wouldn't be against you posting a picture of the
message :)

We try to be as expressive as we can with the error messages, but sometimes
unforeseen things happen and the messages are not so great.  In any case, any
error message is a good starting point to debug the problem.
Comment 2 Angelo Borsotti 2008-02-26 05:26:40 EST
The second message was quite long and at the end it asked whether I wanted
to "debug". It was only text, no pictures and videa. Since these messages
occur in a computing environment that is rather bare, there is no way to
record them, except having a camera at hand. When installing, a lot of
things can go wrong (I had many problems installing Ubuntu too). This is why
the copying and creation of the filesystem should be done from within an
operating system running in normal mode.
I am trying to redo the same operation, this time with a Fedora 32 bits,
and a camera at hand.
For sure, pushing the OK button on message windows should abort installation.
I hope that there are not many places in the installer in which these
message windows occur, and if that is the case, it should be possible to
check what actions are taken.
Comment 3 Joel Andres Granados 2008-02-26 11:23:06 EST
(In reply to comment #2)
> things can go wrong (I had many problems installing Ubuntu too). This is why
> the copying and creation of the filesystem should be done from within an
> operating system running in normal mode.

You should give the fedora livecd a try.  The system would start the
installation from the livecd environment.

> I am trying to redo the same operation, this time with a Fedora 32 bits,
> and a camera at hand.

that would be great.  I think you don't actually need the camera.  I assume you
are in a message box that has a button that states "remote" (if not use camera),
 This button will give you the oportunity to put the anaconda log into someother
computer via network.  The installation environment is restricted but it does
allow some movement.  If you manage to take the log out. please post it. 

> For sure, pushing the OK button on message windows should abort installation.
> I hope that there are not many places in the installer in which these
> message windows occur, and if that is the case, it should be possible to
> check what actions are taken.

Well we try to use the error message in a way that it can give the developers
and users a picture of what is happening.



Comment 4 Angelo Borsotti 2008-02-26 17:30:30 EST
I managed to install Fedora 8 32 bits. No errors were reported during
installation this time.
System startup seems quite slow, at least when compared with Ubuntu,
though.
Comment 5 Joel Andres Granados 2008-02-27 03:34:45 EST
If you see the error pop up again, feel free to open another case or reopen this
one.

Note You need to log in before you can comment on or make changes to this bug.