Bug 434879 - eggcups crashing even with desktop-printing-0.19-20.1.el5
eggcups crashing even with desktop-printing-0.19-20.1.el5
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: desktop-printing (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 18:04 EST by csb sysadmin
Modified: 2013-04-12 15:33 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 05:06:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description csb sysadmin 2008-02-25 18:04:39 EST
Description of problem:

Every now and then eggcups still crashes even with the udpated
desktop-printing-0.19-20.1.el5 rpm


Version-Release number of selected component (if applicable):

0.19-20.1

How reproducible:

all the time

Steps to Reproduce:
1. wait
2. crash occurs
  
Actual results:

crashes and bt is generated:

Memory status: size: 50446336 vsize: 0 resident: 50446336 share: 0 rss:
12537856 rss_rlim: 0
CPU usage: start_time: 1203444297 rtime: 0 utime: 2088 stime: 0
cutime:1229 cstime: 0 timeout: 859 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/eggcups'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208518960 (LWP 2975)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x006c6402 in __kernel_vsyscall ()
#0  0x006c6402 in __kernel_vsyscall ()
#1  0x0087ed6b in waitpid () from /lib/libpthread.so.0
#2  0x045adc26 in gnome_gtk_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x05780ab5 in gtk_tree_model_get_valist ()
   from /usr/lib/libgtk-x11-2.0.so.0
#5  0x05780cad in gtk_tree_model_get () from /usr/lib/libgtk-x11-2.0.so.0
#6  0x080510ec in gtk_marshal_VOID__STRING_INT_POINTER ()
#7  0x00d6b819 in g_cclosure_marshal_VOID__POINTER ()
   from /lib/libgobject-2.0.so.0
#8  0x00d5ef0b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#9  0x00d6fe83 in g_signal_override_class_closure ()
   from /lib/libgobject-2.0.so.0
#10 0x00d7137f in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#11 0x00d71539 in g_signal_emit () from /lib/libgobject-2.0.so.0
#12 0x0804f661 in gtk_marshal_VOID__STRING_INT_POINTER ()
#13 0x0804f85b in gtk_marshal_VOID__STRING_INT_POINTER ()
#14 0x00b09890 in _gnome_cups_request_init ()
   from /usr/lib/libgnomecups-1.0.so.1
#15 0x00cdf5e1 in g_source_is_destroyed () from /lib/libglib-2.0.so.0
#16 0x00ce1342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#17 0x00ce431f in g_main_context_check () from /lib/libglib-2.0.so.0
#18 0x00ce46c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#19 0x056a2b24 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x0804e3e1 in gtk_marshal_VOID__STRING_INT_POINTER ()
#21 0x00716dec in __libc_start_main () from /lib/libc.so.6
#22 0x0804dde1 in gtk_marshal_VOID__STRING_INT_POINTER ()

Thread 1 (Thread -1208518960 (LWP 2975)):
#0  0x006c6402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0087ed6b in waitpid () from /lib/libpthread.so.0
No symbol table info available.
#2  0x045adc26 in gnome_gtk_module_info_get () from
/usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x05780ab5 in gtk_tree_model_get_valist ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#5  0x05780cad in gtk_tree_model_get () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#6  0x080510ec in gtk_marshal_VOID__STRING_INT_POINTER ()
No symbol table info available.
#7  0x00d6b819 in g_cclosure_marshal_VOID__POINTER ()
   from /lib/libgobject-2.0.so.0
No symbol table info available.
#8  0x00d5ef0b in g_closure_invoke () from /lib/libgobject-2.0.so.0
No symbol table info available.
#9  0x00d6fe83 in g_signal_override_class_closure ()
   from /lib/libgobject-2.0.so.0
No symbol table info available.
#10 0x00d7137f in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
No symbol table info available.
#11 0x00d71539 in g_signal_emit () from /lib/libgobject-2.0.so.0
No symbol table info available.
#12 0x0804f661 in gtk_marshal_VOID__STRING_INT_POINTER ()
No symbol table info available.
#13 0x0804f85b in gtk_marshal_VOID__STRING_INT_POINTER ()
No symbol table info available.
#14 0x00b09890 in _gnome_cups_request_init ()
   from /usr/lib/libgnomecups-1.0.so.1
No symbol table info available.
#15 0x00cdf5e1 in g_source_is_destroyed () from /lib/libglib-2.0.so.0
No symbol table info available.
#16 0x00ce1342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#17 0x00ce431f in g_main_context_check () from /lib/libglib-2.0.so.0
No symbol table info available.
#18 0x00ce46c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#19 0x056a2b24 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#20 0x0804e3e1 in gtk_marshal_VOID__STRING_INT_POINTER ()
No symbol table info available.
#21 0x00716dec in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#22 0x0804dde1 in gtk_marshal_VOID__STRING_INT_POINTER ()
No symbol table info available.
#0  0x006c6402 in __kernel_vsyscall ()

Expected results:

should not crash

Additional info:
Comment 1 Tim Waugh 2008-02-26 06:28:59 EST
I'm not seeing that here, so I'll need to ask you for some more information.

Please install desktop-printing-debuginfo, gtk2-debuginfo and glib2-debuginfo. 
I'd like to see:

1. output of: rpm -q {desktop-printing,gtk2,glib2}{,-debuginfo}
2. resulting eggcups backtrace with debuginfo packages installed

Thanks.
Comment 2 csb sysadmin 2008-02-26 11:58:12 EST
I can't find any of the -debuginfo packages on rhn.redhat or our internal rhn.
Comment 3 csb sysadmin 2008-02-26 12:10:09 EST
nm, i found them via pbone
Comment 4 Tim Waugh 2008-05-06 11:49:47 EDT
Still need the backtrace with symbols; see comment #1.
Comment 5 Tim Waugh 2008-05-09 05:07:20 EDT
The key to reproducing this one seems to be:

1. Submit a job to a queue on a remote server
2. Restart cups
Comment 8 Phil Knirsch 2008-05-14 10:15:41 EDT
Proposing bug for RHEL-5.3 FasTrack and granting Devel ACK.

Read ya, Phil
Comment 12 errata-xmlrpc 2008-06-12 05:06:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0530.html

Note You need to log in before you can comment on or make changes to this bug.