Bug 434905 - lvm2-cluster shipped in F8 is incompatible with dlm version of the kernel
lvm2-cluster shipped in F8 is incompatible with dlm version of the kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cman (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Fabio Massimo Di Nitto
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 00:23 EST by Alex
Modified: 2008-06-06 03:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: 0.80.3-17.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 03:47:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex 2008-02-26 00:23:44 EST
Description of problem:

The version of lvm2-cluster shipped with Fedora 8 is incompatible with the dlm
module shipped in the kernel.

The cluster is otherwise working normally. Only CLVM is not starting.

Version-Release number of selected component (if applicable):

# uname -a
Linux testsys 2.6.23.15-137.fc8 #1 SMP Sun Feb 10 17:03:13 EST 2008 x86_64
x86_64 x86_64 GNU/Linux
# rpm -qa | grep lvm
lvm2-2.02.28-1.fc8
lvm2-cluster-2.02.28-1.fc8


How reproducible:

It is reproducible all the times with Fedora 8 freshly installed or with the
latest patches.

Steps to Reproduce:

When trying to start clvmd:
# lsmod | grep dlm
lock_dlm               28745  1
gfs2                  484853  1 lock_dlm
dlm                   120673  5 lock_dlm
configfs               32477  2 dlm

# service clvmd start
Starting clvmd: clvmd could not connect to cluster manager
Consult syslog for more information
                                                           [FAILED]
The following message appears in /var/log/messages:
Feb 26 12:15:52 prdc1dba01 clvmd: Unable to create lockspace for CLVM: Invalid
exchange

And in dmesg:
dlm: process clvmd (3773) version mismatch user (5.0.0) kernel (6.0.0)

  
Actual results:

clvmd fails to start even though the cluster is working normally and the dlm
kernel modules are loaded properly. It seems from the messages that clvmd is not
speaking the same version of the locking language as the kernel (5 vs 6)

Expected results:

clvmd should start.

Additional info:

The problem seems also to exist when installing the latest LVM packages from
Rawhide on top of Fedora 8...
Comment 1 Alex 2008-02-26 02:54:40 EST
After investigating further, the problem seems to come from libdlm, which is
part of the cman package.

The version of libdlm in cman seems to only support version DLM device 5.0.0
while the kernel has switched to 6.0.0 since 2.6.22.

So the bug should be reassigned to cman.

Alex


Comment 2 Christine Caulfield 2008-02-26 04:00:53 EST
It looks like the cman package in Fedora hasn't been updated for some time and
the kernel has moved on to the new DLM interface.

The newer libdlm can handle older and newer kernels, but the older libdlm can't
handle newer kernels.

So we need a new cman package for Fedora. Building it off the RHEL5 branch
should do.
Comment 3 Fedora Update System 2008-06-02 16:32:59 EDT
rgmanager-2.03.03-1.fc9,gfs2-utils-2.03.03-1.fc9,cman-2.03.03-1.fc9,openais-0.80.3-17.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-06-03 03:30:07 EDT
openais-0.80.3-17.fc9, rgmanager-2.03.03-1.fc9, cman-2.03.03-1.fc9, gfs2-utils-2.03.03-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openais rgmanager cman gfs2-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4848
Comment 5 Fedora Update System 2008-06-06 03:47:48 EDT
openais-0.80.3-17.fc9, rgmanager-2.03.03-1.fc9, cman-2.03.03-1.fc9, gfs2-utils-2.03.03-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.