Bug 434929 - .vym files are opening with archive manager
.vym files are opening with archive manager
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: vym (Show other bugs)
el5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 06:51 EST by Marek Mahut
Modified: 2008-06-26 04:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 15:03:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Mahut 2008-02-26 06:51:29 EST
Description of problem:

on EL5, .vym files are by default opened by archive manager.
Comment 1 Gwyn Ciesla 2008-02-26 09:33:11 EST
Hmm. On Fedora 8, they open in Wine.  Not sure this is a vym bug.  How do we
package the addition of a mime type to Nautilus, et. al.?
Comment 2 Till Maas 2008-03-12 18:03:22 EDT
Maybe it is because it is zip data:

$ file foo.vym
foo.vym: Zip archive data, at least v2.0 to extract

To create a new mimetype I guess one has to follow this procedure:
http://www.iana.org/cgi-bin/mediatypes.pl
Comment 3 Gwyn Ciesla 2008-04-09 11:41:47 EDT
Since it's zip data, I don't see how we'd reliably know whether a given file was
a vym file or not, save for the extension. I could add a MimeType entry to the
.desktop file for zip files, so it would appear in the Other Applications dialog.

Would that be sufficient?
Comment 4 Marek Mahut 2008-04-09 12:01:26 EDT
(In reply to comment #3)
> Would that be sufficient?

Is there any way to associate file type by extension? 

Comment 5 Gwyn Ciesla 2008-04-09 12:09:28 EDT
Only by mimetype AFAIK.  Taking xmms as an example, the only refence to file
type is in the .desktop, which lists the mime types to be associated with xmms.
 I could to the same for zip and vym, but it's be as one choice, not a default,
since zip is openable by name things, such as gnome-file-roller, etc.
Comment 6 Till Maas 2008-05-29 13:50:08 EDT
I just found something out: The vim-vimoutliner package uses a file
(/usr/share/mime/packages/vimoutliner.xml) to define its own mimetype
(text/x-vimoutliner) and in this file it is also possible to specify a filename
pattern. Therefore I guess you could do this for vym, too. I am currently
working on something else, but I will do some more research later unless I
forget it. ;-)
Comment 7 Gwyn Ciesla 2008-05-29 13:56:23 EDT
Looks like I'd essentially copy the .zip one, and use the .vym extenstion.
Comment 8 Till Maas 2008-05-29 14:40:53 EDT
(In reply to comment #7)
> Looks like I'd essentially copy the .zip one, and use the .vym extenstion.

Maybe you should add <sub-class-of type="application/zip"/> then. Other zipped
xml mimetypes do this, too, e.g.
/usr/share/mime/application/vnd.oasis.opendocument.chart.xml

Comment 9 Gwyn Ciesla 2008-06-10 14:50:44 EDT
Hmm. Didn't know about this:
http://fedoraproject.org/wiki/NewMIMESystem

It worked.  Build for rawhide failed due to 450310, which should be fixed
tomorrow.  I'll keep the builds moving through and let you know when it's built
for EPEL.
Comment 10 Till Maas 2008-06-10 19:20:41 EDT
(In reply to comment #9)
> Hmm. Didn't know about this:
> http://fedoraproject.org/wiki/NewMIMESystem

This is only about how you make applications open a specific mimetype. What is
missing is how you assign mimetypes to a file, e.g. for all files with a certain
suffix.

> It worked.  Build for rawhide failed due to 450310, which should be fixed
> tomorrow.  I'll keep the builds moving through and let you know when it's built
> for EPEL.

xdg-open Foo.vym with a local build of rawhide does still open the file with an
archive manager. You still need to add an file that creates the link between
file extension and mimetype.
Comment 11 Gwyn Ciesla 2008-06-11 08:36:49 EDT
Ah.  Updated to include that, xdg-open works.  Can't commit to cvs, though,
waiting out the DNS issue.
Comment 12 Gwyn Ciesla 2008-06-12 09:57:05 EDT
Built in rawhide.
Comment 13 Fedora Update System 2008-06-12 14:58:20 EDT
vym-1.10.0-4.fc9 has been submitted as an update for Fedora 9
Comment 14 Fedora Update System 2008-06-12 14:59:48 EDT
vym-1.10.0-4.fc8 has been submitted as an update for Fedora 8
Comment 15 Gwyn Ciesla 2008-06-12 15:03:49 EDT
Built for EL-5 as well.
Comment 16 Fedora Update System 2008-06-26 04:31:56 EDT
vym-1.10.0-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2008-06-26 04:33:49 EDT
vym-1.10.0-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.