Bug 434935 - TBb9d8707e Conf.py:1016:__setitem__:NameError: global name 'join' is not defined
TBb9d8707e Conf.py:1016:__setitem__:NameError: global name 'join' is not defined
Status: CLOSED DUPLICATE of bug 437678
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 436261 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 08:12 EST by Robin Green
Modified: 2008-03-31 07:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 07:02:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2008-02-26 08:12:44 EST
I created a profile, edited it and tried to save it. At this point I got an
exception:

Component: system-config-network
Version: 1.4.7
Summary: TBb9d8707e Conf.py:1016:__setitem__:NameError: global name 'join' is
not defined

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
808, in on_applyButton_clicked
    self.save()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
371, in save
    self.saveHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
399, in saveHardware
    hardwarelist.save()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
873, in save
    modules.write()
  File "/usr/share/system-config-network/netconfpkg/conf/Conf.py", line 1044, in
write
    self[key] = self.vars[key]
  File "/usr/share/system-config-network/netconfpkg/conf/Conf.py", line 1016, in
__setitem__
    comment = join(cl[1:], '#')
NameError: global name 'join' is not defined

Local variables in innermost frame:
findexp: ^[	 ]*install[	 ]+snd-via82xx-modem[	 ]+
missing: 1
varname: snd-via82xx-modem
self: <netconfpkg.NCHardwareList.MyConfModules instance at 0xb7986a4c>
cl: ['install snd-via82xx-modem /bin/true ', ' temporarily disabled by hsf -
conflicts with hsfmc97via']
value: {'alias': '', 'options': {}, 'install': ['/bin/true', '#', 'temporarily',
'disabled', 'by', 'hsf', '-', 'conflicts', 'with', 'hsfmc97via'], 'remove': []}
replace: install snd-via82xx-modem /bin/true # temporarily disabled by hsf -
conflicts with hsfmc97via
place: 0
key: install
endofline: /bin/true # temporarily disabled by hsf - conflicts with hsfmc97via
Comment 1 Harald Hoyer 2008-02-26 08:27:55 EST
quickfix:
/usr/share/system-config-network/netconfpkg/conf/Conf.py line 172:
change
from string import joinfields, split, find
to
from string import joinfields, split, find, join
Comment 2 Robin Green 2008-02-26 18:26:56 EST
yes, thanks, that fixed it for me
Comment 3 Harald Hoyer 2008-03-31 06:47:54 EDT
*** Bug 436261 has been marked as a duplicate of this bug. ***
Comment 4 Harald Hoyer 2008-03-31 07:02:08 EDT

*** This bug has been marked as a duplicate of 437678 ***

Note You need to log in before you can comment on or make changes to this bug.