Bug 434991 - glibc reports invalid free for nsswitch binary
Summary: glibc reports invalid free for nsswitch binary
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs   
(Show other bugs)
Version: 4.6
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Jeff Moyer
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-26 18:45 UTC by Jeff Moyer
Modified: 2008-07-24 19:51 UTC (History)
1 user (show)

Fixed In Version: RHBA-2008-0702
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 19:51:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Don't free the domainname returned from yp_get_default_domain (601 bytes, patch)
2008-02-26 18:45 UTC, Jeff Moyer
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0702 normal SHIPPED_LIVE autofs bug fix and enhancement update 2008-07-23 15:43:37 UTC

Description Jeff Moyer 2008-02-26 18:45:34 UTC
Description of problem:
lib/nsswitch.c uses yp_get_default_domain to determine the yp domain name.  The
pointer passed back apparently should not be passed to free.  Glibc spewed an
error about this and terminated the program.

Version-Release number of selected component (if applicable):
autofs-4.1.3-231

How reproducible:
100%

Steps to Reproduce:
Run the regression test /CoreOS/autofs/bugzillas, subtest bz212249.

Comment 1 Jeff Moyer 2008-02-26 18:45:34 UTC
Created attachment 295978 [details]
Don't free the domainname returned from yp_get_default_domain

Comment 2 RHEL Product and Program Management 2008-02-26 18:47:49 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 RHEL Product and Program Management 2008-02-26 18:49:15 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 5 Jeff Moyer 2008-02-27 18:12:05 UTC
A fix for this issue was committed to CVS and will appear in autofs versions
4.1.3-231.8 and later.  Test packages can be found at:
  http://people.redhat.com/~jmoyer/


Comment 7 Barry Donahue 2008-06-12 14:34:59 UTC
Verified by RHTS job #23575

Comment 9 errata-xmlrpc 2008-07-24 19:51:47 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0702.html


Note You need to log in before you can comment on or make changes to this bug.