Bug 43501 - ppp-watch fails to continue to retry dialing when power fails on external modem.
Summary: ppp-watch fails to continue to retry dialing when power fails on external modem.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-05 12:28 UTC by Oliver Jones
Modified: 2007-04-18 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 09:28:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oliver Jones 2001-06-05 12:28:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0) - So sue 
me, I'm using Win2k...  Exceed sucks at rendering the fonts in Moz/5. No 
local consoles with mice.  ;)

Description of problem:
ppp-watch fails to continue to retry dialing when power fails on external 
modem.  

When testing my UPS on a RedHat 7.1 I noted that when power failed (the 
modem isn't on the ups) ppp-watch and wvdial failed to reconnect to the 
Internet.  

I have enabled redial on disconnect in rp3-config for ppp0.  The 
PERSIST=true line is defined in the ifcfg-ppp0 file.  

How reproducible:
Always

Steps to Reproduce:
1. Set ppp0 to redial on disconnect.
2. Connect to the Internet with RH7.1 via a dialup device (ppp0).  
3. Yank the power out of your external modem.  Or press the power switch, 
whatever gives you most joy.
4. Reconnect the power to your modem.
5. Watch in awe as ppp-watch fails to reconnect you to the internet
6. "ps ax |grep ppp" and discover that there is no trace of ppp-watch, 
pppd or wvdial to be seen.


Actual Results:  The internet connectivity is not there.

Expected Results:  The internet connectivity should have returned.

Additional info: I consider this a bug or at least a misfeature.

Comment 1 Anthony Rumble 2001-07-02 23:11:30 UTC
We are seeing this also with a number of clients.. It normally redials.. but 
under certain circumstances, it stops redialling. Most likely due to some sort
of backoff code they have added. RH 7.0 would redial till the end of time.. but
now, we are having to explain to customers over the phone at least once a week
how to start their ppp again.

Comment 2 Richard Ames 2001-08-20 07:40:11 UTC
Possibly same fix as 39231??

Comment 3 Thomas Woerner 2004-08-13 09:28:11 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.



Note You need to log in before you can comment on or make changes to this bug.