Bug 435036 - autofs fails if nsswitch.conf doesn't have automount entry
autofs fails if nsswitch.conf doesn't have automount entry
Status: CLOSED DUPLICATE of bug 429340
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Jeffrey Moyer
Brock Organ
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 17:50 EST by Jeffrey Moyer
Modified: 2008-02-27 13:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 13:03:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Assume configuration lives in files if no nsswitch.conf line for automount (486 bytes, patch)
2008-02-26 17:50 EST, Jeffrey Moyer
no flags Details | Diff

  None (edit)
Description Jeffrey Moyer 2008-02-26 17:50:08 EST
+++ This bug was initially created as a clone of Bug #332291 +++

Description of problem:

If /etc/nsswitch.conf doesn't have an entry for automount
autofs fails to start.

Version-Release number of selected component (if applicable):
autofs-4.1.3-231

How reproducible:
Always.

Steps to Reproduce:
Remove the line starting with "automount:" from
/etc/nsswitch.conf and try and start autofs.
  
Actual results:
autofs fails to start.

Expected results:
autofs should use files as the source of maps if there is
no entry in the nsswitch configuration.

-- Additional comment from ikent@redhat.com on 2007-11-13 01:56 EST --
An RHTS test case for this bug has been added under autofs-tests/bugzillas,
subtest bz332291.
Comment 1 Jeffrey Moyer 2008-02-26 17:50:08 EST
Created attachment 296001 [details]
Assume configuration lives in files if no nsswitch.conf line for automount
Comment 2 RHEL Product and Program Management 2008-02-26 18:08:28 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Jeffrey Moyer 2008-02-27 13:03:44 EST
Clearly I am sufferring from lack of sleep -- or something!

*** This bug has been marked as a duplicate of 429340 ***

Note You need to log in before you can comment on or make changes to this bug.