Bug 435041 - /etc/modprobe.conf balloons to a ridiculously huge size (12 MB)
/etc/modprobe.conf balloons to a ridiculously huge size (12 MB)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 18:33 EST by Robin Green
Modified: 2008-03-31 08:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 08:42:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2008-02-26 18:33:21 EST
Description of problem:
/etc/modprobe.conf grows quickly (exponentially?) every time it is edited by
system-config-network, if it has a certain style of comments already in it. This
causes slowdowns.

Version-Release number of selected component (if applicable):
system-config-network-1.4.7-1.fc8

My /etc/modprobe.conf grew to 12MB which is a bit too large to attach to
bugzilla. Here is the head of it:

# Note: for use under 2.4, changes must also be made to modules.conf!
alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias /dev/modem /dev/ttySHSF
alias char-major-240 /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
options hsfserial serialmajor=240
alias char-major-242 hsfosspec
alias char-major-242-* hsfosspec
alias /dev/hsfdiag hsfosspec
alias /dev/hsfdiag* /dev/hsfdiag
alias char-major-243 /dev/hsfdiag
alias char-major-243-* /dev/hsfdiag
options hsfosspec dcpmajor=242 diagmajor=243
install /dev/ttySHSF /sbin/modprobe hsfpcibasic2; /sbin/modprobe hsfpcibasic3;
/sbin/modprobe hsfmc97ich; /sbin/modprobe hsfmc97via; /sbin/modprobe hsfmc97ali;
/sbin/modprobe hsfmc97ati; /sbin/modprobe hsfmc97sis; [ -e /lib/modules/`uname
-r`/extra/hsfusbcd2.ko ] && /sbin/modprobe hsfusbcd2; /sbin/modprobe
snd_hda_intel; /bin/true
alias symbol:cnxthwhda_probe hsfhda
alias symbol:cnxthwhda_resume hsfhda
alias symbol:cnxthwhda_suspend hsfhda
install snd-via82xx-modem /bin/true # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with hsfmc97via # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with hsfmc97via # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with hsfmc97via # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with hsfmc97via # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with hsfmc97via # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with hsfmc97via # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with hsfmc97via # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with hsfmc97via # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with hsfmc97via # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with hsfmc97via # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with hsfmc97via # temporarily disabled by hsf - conflicts
with hsfmc97via # temporarily disabled by hsf - conflicts with hsfmc97via #
temporarily disabled by hsf - conflicts with hsfmc97via # temporarily disabled
by hsf - conflicts with

I think it's obvious here what is going wrong. The comment is being duplicated -
I suspect by some code in system-config-network.
Comment 1 Robin Green 2008-02-26 18:35:16 EST
Of course, it could instead be the fault of the hsf installer, which I also ran
several times. I am not sure, because I do not remember if modprobe.conf was
this large before I ran system-config-network.
Comment 2 Harald Hoyer 2008-03-31 08:42:25 EDT
system-config-network-1.5.4

Note You need to log in before you can comment on or make changes to this bug.