Bug 435071 - 3.25: Foreign key support in DB schema.
3.25: Foreign key support in DB schema.
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Database (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Tony Fu
:
Depends On: 435072 435073 436921 437734 437735 437736 437915 437920 440366 441176 441180 441181 441183 441196 441201 441208 441212
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 01:28 EST by Tony Fu
Modified: 2013-06-24 00:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 02:23:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 109473 None None None Never

  None (edit)
Description Tony Fu 2008-02-27 01:28:56 EST
Create this bug to track the progress of submitting FKs code to upstream.

+++ This bug was initially created as a clone of Bug #406351 +++

Description:
Red Hat has added referential integrity checks to the database schema to ensure
against any foreign key violations. Upstream Bugzilla code has implemented some
initial support for foreign keys as well.

Function Requirements:
MySQL 5+ redhat/bugs-fk.mysql

-- Additional comment from tfu@redhat.com on 2007-12-18 01:17 EST --
It is implemented in bugs-fk.mysql file.  I used historical method and the LOC
is 640.

-- Additional comment from kbaker@redhat.com on 2007-12-18 08:36 EST --
Tony, how do you get 640 lines? I would expect that you only have to add
the FK constraints. That would be around 100LOC, no?

-- Additional comment from tfu@redhat.com on 2007-12-18 20:26 EST --
I used cloc to calculate the LOC of our existing db schema file, which includes
FK constraints and all talbes definition as well.  For FK constraints only,
100LOC is a reasonable number.

Changing LOC to 100.

-- Additional comment from tfu@redhat.com on 2008-01-10 01:17 EST --
Added FKs constraints in Bugzilla/DB/Schema.pm file.  Please refer to bug #420611.

-- Additional comment from tfu@redhat.com on 2008-01-24 20:16 EST --
Submitted a Bugzilla/DB/Schema.pm patch, which included all foreign key
constraints, to upstream for review.

-- Additional comment from dkl@redhat.com on 2008-01-24 22:02 EST --
Tony please attach the upstream bug link to this bug so we can keep track of it.
Either in the External Bugzilla References section or in the URL text field.

Thanks

-- Additional comment from tfu@redhat.com on 2008-02-11 02:21 EST --
Get review feedback from upstream.

Update the schema according to the feedback and submitted new patch for upstream
review.

-- Additional comment from dkl@redhat.com on 2008-02-14 00:32 EST --
Do we already have this in our 3.2 tree? If not we will need a patch for this
bug so hit our first milestone.

Dave

-- Additional comment from tfu@redhat.com on 2008-02-14 01:57 EST --
(In reply to comment #8)
> Do we already have this in our 3.2 tree? If not we will need a patch for this
> bug so hit our first milestone.
> 
> Dave

It should have been included in Bugzilla/DB/Schema.pm I attached in #420611.


Tony

-- Additional comment from tfu@redhat.com on 2008-02-15 02:24 EST --
Will create a new bug to track the progress of mergering FKs constraints into
upstream code.

Close this bug.
Comment 1 David Lawrence 2008-05-30 11:13:01 EDT
Tony, how are we doing with this bug? Do we have all of the needed FK changes
now submitted upstream? If yes, we can probably close this bug as NEXTRELEASE
since we have the FK support in our code as well.

Thanks
Dave
Comment 2 David Lawrence 2008-05-30 11:31:31 EDT
Also please close all of the dependencies on this bug if they are also in the
current beta code base.

Thanks
Dave

Note You need to log in before you can comment on or make changes to this bug.