Bug 435085 - localation of man output forced to utf-8
localation of man output forced to utf-8
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Peter Schiffer
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 05:21 EST by Klaus Ethgen
Modified: 2013-01-10 12:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-10 12:24:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Ethgen 2008-02-27 05:21:27 EST
Description of problem:
The output of man (the command itself) is always UTF-8. This is horrible with
language settings to other encodings.

Version-Release number of selected component (if applicable):
1.6d-1.1

How reproducible:
export LANG=de_DE
export LC_MESSAGES=de_DE
man bla

Actual results:
Keine Handbuchseite für bla

Expected results:
Keine Handbuchseite für bla

Additional info:
There is no UTF-8 cable environment in use! The terminal is xterm with no "-u8"
command line option and all language settings are the normal de_DE settings.
Also setting of explicit ".ISO-8859-1" does not work.
Comment 1 Ivana Varekova 2010-04-14 06:41:22 EDT
Hello, this seems to be xterm problem.
Comment 2 Miroslav Lichvar 2010-04-14 06:45:04 EDT
Actually, that would be a problem with nroff if it produces utf8 output in non-utf8 locale.
Comment 3 Ivana Varekova 2010-05-18 08:06:51 EDT
Hello,
I try to reproduce the problem but I was unsuccesfull, is there any other settings you use?
Comment 4 Petr Pisar 2010-06-06 19:17:45 EDT
This is not about nroff output. It's about `man' utility itself.

The utility is not locale charset aware. The reason is man uses POSIX message catalogues instead of GNU gettext. POSIX catalogues do not save charset of catalogue at compile time and thus do not provide run-time recoding to current locale charset.
Comment 5 RHEL Product and Program Management 2011-09-22 20:08:59 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 Peter Schiffer 2013-01-10 12:24:56 EST
I am closing this bug. As Petr explained in comment 4, the fix is not trivial and it's too late for extensive patches in RHEL-5. Also, this problem doesn't occur in RHEL-6.

peter

Note You need to log in before you can comment on or make changes to this bug.