Bug 435143 - RHEL4U6 - system-config-cluster looks for /usr/sbin/cman_tool instead of /sbin/cman_tool
RHEL4U6 - system-config-cluster looks for /usr/sbin/cman_tool instead of /sbi...
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jim Parsons
Cluster QE
: ZStream
Depends On:
Blocks: 441353
  Show dependency treegraph
 
Reported: 2008-02-27 11:46 EST by Shane Bradley
Modified: 2010-10-22 18:50 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0792
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 15:07:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Bradley 2008-02-27 11:46:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
system-config-cluster-1.0.51-2.0.el4_6.1 looks for /usr/sbin/cman_tool which doesn't exist with cman-1.0.17-0.el4_6.3.  

I have tested the latest builds from brewroot and get the same result:
cman-1.0.17-0.el4_6.5  system-config-cluster-1.0.51-2.0.el4_6.1

Appears that cman package does not create the required symlink that is needed to be compatible with system-config-cluster(RHEL5 does not require symlink since default location is in /usr/sbin/cman_tool)

Here is a related BZ on RHEL5 issue:
https://bugzilla.redhat.com/show_bug.cgi?id=233621

--sbradley


Version-Release number of selected component (if applicable):
cman-1.0.17-0.el4_6.5  system-config-cluster-1.0.51-2.0.el4_6.1

How reproducible:
Always


Steps to Reproduce:
Steps to reproduce:
1. Configure cluster.conf
2. Start cluster services (ccsd, cman)
3. Open system-config-cluster and click on Management tab

Actual Results:
Error message stating "Node information is temporarily unavailable.  Here is the error message: A problem was encountered when attempting to get information about the nodes in the cluster: /bin/bash: /usr/sbin/cman_tool: No such file or directory"


Expected Results:
Management interface available since cluster is started and member is joined

Additional info:
Workaround:
  # ln -s /sbin/cman_tool /usr/sbin/cman_tool

Additional info: In /usr/share/cluster/CommandHandler.py, /usr/sbin/cman_tool appears on the following lines: 78, 82, 216, 220, 239, 243, 284, 288, 313, 317, 479, 485
Comment 1 Shane Bradley 2008-02-27 11:55:53 EST
The issue appears to be related to the change in RHEL5. 
I believe the system-config-cluster package was based on the RHEL5
system-config-cluster which uses the path /usr/sbin/cman_tool instead of RHEL4
location of /sbin/cman_tool. 

The package system-config-cluster-1.0.45 uses the correct RHEL4 path
/sbin/cman_tool.

I believe a symlink is needed on package install.
$ ln -s /sbin/cman_tool /usr/sbin/cman_tool
Comment 2 Juanjo Villaplana 2008-03-13 08:25:11 EDT
This system-config-cluster version seems not compatible with RHEL4, the "Cluster
Managemnt" tab doesn't work as expected: Name and Status columns on the Members
section show incorrect values.

From /usr/share/system-config-cluster/CommandHandler.py it seems that NodeData
instances aren't initialized in the right way (at least for DLM clusters).

system-config-cluster-1.0.51-2.0 + bz398291 fix works fine for us.
Comment 3 RHEL Product and Program Management 2008-03-17 12:28:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Jon Wilson 2008-03-19 01:41:27 EDT
I can confirm that this bug exists. The severity should be increased, because it
makes system-config-cluster unusable (without the symlink workaround).

So much for release QA, hey folks!
Comment 12 errata-xmlrpc 2008-07-25 15:07:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0792.html

Note You need to log in before you can comment on or make changes to this bug.