Bug 435149 - smb4k is causing problem with sudo
smb4k is causing problem with sudo
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: smb4k (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 11:52 EST by Neal Becker
Modified: 2008-07-31 21:46 EDT (History)
0 users

See Also:
Fixed In Version: 0.9.6-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-31 21:46:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2008-02-27 11:52:50 EST
Description of problem:

New version of sudo has env_keep = {various stuff} in the default rpm.

I think instead of:
 Defaults:SMB4KUSERS	env_keep=PASSWD
please use:
 Defaults:SMB4KUSERS	env_keep+=PASSWD
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Update System 2008-02-27 18:39:54 EST
smb4k-0.9.3-1.fc8 has been submitted as an update for Fedora 8
Comment 2 Fedora Update System 2008-02-28 16:39:28 EST
smb4k-0.9.3-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smb4k'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2069
Comment 3 Neal Becker 2008-02-29 09:48:32 EST
I tried this on 1 machine.  If I click on setting/configure, I get:
Library files for "libsmb4kconfigdialog.la" not found in paths.

Strangely, on another machine trying to do yum --enablerepo=updates-testing 
install smb4k wanted to pull in lots of stuff:

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kdebase-libs            x86_64     6:3.5.9-1.fc8    updates-testing   1.0 M
     replacing  kdebase.x86_64 6:3.5.8-32.fc8

 smb4k                   i386       0.9.3-1.fc8      updates-testing   1.8 M
Updating:
 arts                    x86_64     8:1.5.9-1.fc8    updates-testing   1.2 M
 kdelibs                 x86_64     6:3.5.9-3.fc8    updates-testing    17 M
 smb4k                   x86_64     0.9.3-1.fc8      updates-testing   1.8 M
Installing for dependencies:
 arts                    i386       8:1.5.9-1.fc8    updates-testing   1.2 M
 kdelibs                 i386       6:3.5.9-3.fc8    updates-testing    17 M
 qt                      i386       1:3.3.8b-2.fc8   updates           3.6 M
Updating for dependencies:
 arts-devel              x86_64     8:1.5.9-1.fc8    updates-testing   213 k
 kdebase                 x86_64     6:3.5.9-1.fc8    updates-testing    28 M
 kdebase-devel           x86_64     6:3.5.9-1.fc8    updates-testing   125 k
 kdelibs-devel           x86_64     6:3.5.9-3.fc8    updates-testing   2.4 M

I didn't want to try it, since that is my primary machine.
Comment 4 Marcin Garski 2008-02-29 18:47:37 EST
Next build will fix .la problem. When it appear in updates-testing repo please
update to it and test.

It pull in lots of stuff because you try to install smb4k in both versions, for
i386 and  x86_64, try to update it with:
su -c 'yum --enablerepo=updates-testing update smb4k.x86_64'
Comment 5 Fedora Update System 2008-02-29 19:00:51 EST
smb4k-0.9.3-2.fc8 has been submitted as an update for Fedora 8
Comment 6 Neal Becker 2008-02-29 19:07:34 EST
I don't think this is a good design.
User_Alias      SMB4KUSERS = nbecker
SMB4KUSERS      nbecker4 = NOPASSWD: /usr/bin/smb4k_kill
SMB4KUSERS      nbecker4 = NOPASSWD: /usr/bin/smb4k_umount
SMB4KUSERS      nbecker4 = NOPASSWD: /usr/bin/smb4k_mount
Defaults:SMB4KUSERS     env_keep+="PASSWD USER"

I'm no expert, but IIUC that means it's changing defaults for those users 
(e.g., me).

It shouldn't be changing global default settings.  Am I wrong here?
Comment 7 Fedora Update System 2008-07-30 12:48:20 EDT
smb4k-0.9.6-1.fc8 has been submitted as an update for Fedora 8
Comment 8 Fedora Update System 2008-07-31 21:46:05 EDT
smb4k-0.9.6-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.