Bug 435213 - OpenOffice.org does not start with fglrx driver and dualhead
OpenOffice.org does not start with fglrx driver and dualhead
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 435212 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 18:17 EST by Nicola Romanò
Modified: 2008-03-04 10:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 10:25:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (4.30 KB, text/plain)
2008-02-27 18:19 EST, Nicola Romanò
no flags Details
Xorg log file (3.79 MB, text/plain)
2008-02-28 20:02 EST, Nicola Romanò
no flags Details

  None (edit)
Description Nicola Romanò 2008-02-27 18:17:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
Openoffice.org won't start at all when dualhead is enabled using xinerama with fglrx driver.
Launching the software from commandline (openoffice.org -writer) doesn't give any output, the cursor just stalls.

I'm using fglrx driver with a ATI Mobility Radeon X1600
1st monitor: 1280x800, 2nd monitor: 1280x1024 (attached xorg.conf)

ati or radeonhd drivers don't have this problem, but apparently they have problems with dual head with different resolutions (or, at least, I can't make it work).

See for reference: http://www.oooforum.org/forum/viewtopic.phtml?p=275392



Version-Release number of selected component (if applicable):
openoffice.org-core-2.3.0-6.11.fc8

How reproducible:
Always


Steps to Reproduce:
1.setup a dual head system with xinerama (with different resolutions? not sure) using fglrx driver (see attached xorg.conf)
2.open openoffice.org

Actual Results:


Expected Results:


Additional info:
Comment 1 Nicola Romanò 2008-02-27 18:19:41 EST
Created attachment 296139 [details]
xorg.conf

xorg.conf for dual-head setup with fglrx/xinerama
Comment 2 Caolan McNamara 2008-02-28 03:25:22 EST
*** Bug 435212 has been marked as a duplicate of this bug. ***
Comment 3 Caolan McNamara 2008-02-28 03:33:58 EST
fglrx a proprietary driver that's not supplied by fedora, so you're mostly out
of luck here unless it can be reproduced with a non-proprietary driver.

That said I suggest you attach your /var/log/Xorg.0.log and your
/var/log/messages and the output of /usr/sbin/sestatus e.g. there might be a
problem with your fglrx and selinux for example.
Comment 4 Nicola Romanò 2008-02-28 20:02:01 EST
Created attachment 296295 [details]
Xorg log file

Attached Xorg.0.log file.
Can't seem to find any /var/log/messages file on my computer.

sestatus outputs 

SELinux status: 		enabled
SELinuxfs mount:		/selinux
Current mode:			permissive
Mode from config file:		permissive
Policy version: 		21
Policy from config file:	seedit
Comment 5 Nicola Romanò 2008-02-28 22:15:25 EST
I managed to find a temporary solution to the problem.

1) start a second X session with Xephyr

Xephyr -xinerama -ac -screen 1280x1024 :2

2) Start a KDE desktop inside (I'm running gnome and for whatever reason I can't
seem to start another Gnome desktop) with:

DISPLAY=:2 startkde

3) Open OO in KDE, it works!

I guess the opposite would also work (login with KDE, open Gnome in Xephyr), but
haven't tried.
Comment 6 Caolan McNamara 2008-02-29 03:14:10 EST
Your logs are riddled with loads of...

(EE) fglrx(1): [DRI] Locking deadlock.
	Already locked with context 153779292,
	trying to lock with context 24.
(EE) fglrx(1): [DRI] Unlocking inconsistency:
	Context 153779292 trying to unlock lock held by context 24

which looks pretty bad, perhaps googling for that or checking the
bugzilla/forums of the vendor which provides this 3rd party driver might be the
best thing to do.

As a possibility its possibly worth giving 

> export SAL_NOOPENGL=1
> oowriter

a go to see if disabling using opengl works around the immediate problem


Comment 7 Caolan McNamara 2008-03-04 10:25:55 EST
I strongly suspect that this is the driver, not OOo.

Note You need to log in before you can comment on or make changes to this bug.