Bug 435338 - www.s.com as start page
www.s.com as start page
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
: 446317 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2008-02-28 14:33 EST by Horst H. von Brand
Modified: 2009-02-19 08:54 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-16 14:34:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-02-28 14:33:51 EST
Description of problem:
Whan firefox starts, it tries to show the (non-existent) page http://www.s.com.
If Firefox is killed, and then restarted, it loads the pages it was showing
before and also tries to show this one.

Edit -> Preferences -> Main has "Show my home page" and

Version-Release number of selected component (if applicable):
firefox-3.0-0.beta3.29.nightly20080227.fc9.i386 (but has been happening for some
time now)

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Matěj Cepl 2008-02-28 17:27:45 EST
Have you ever changed your homepage?
Comment 2 Horst H. von Brand 2008-02-28 21:22:09 EST
Some time back, Firefox showed only a blank page and I tried to get it to show
the default page, with no success (the place for the URL just was blank, and you
couldn't write into it, or at least it didn't stick). Some updates later, the
default homepage showed, then this http://www.s.com thing, then it worked again,
now it is again broken.

Any files I should move out of the way to make it "forget" this nonsense? (I'd
hate to loose passwords and such, but...).
Comment 3 Matěj Cepl 2008-02-29 08:03:14 EST
Give me please output of this command

grep 'browser.startup.homepage' ~/.mozilla/firefox/*default/prefs.js

to see what you have officially set up there.

The official location of setting homepage is in prefs.js file found in your
profile directory, so you can try to move the file out of the way (just for
testing purposes and firefox has to be down when the move happens). Will it
help? Of course, manual removing of the offending line from the prefs.js should

However, the question is why in the world it got there in the first place...
Comment 4 Horst H. von Brand 2008-02-29 08:33:33 EST

www.s.com doesn't show in that file.

At first I thought it was some kind of leftover after fat-fingering an URL, but
I saw messages on fedora-devel-list complaining about the very same. Didn't get
around to report it until now.
Comment 5 Horst H. von Brand 2008-02-29 12:23:43 EST
I moved the prefs.js file to prefs.js.SAVE and tried again. X had gone south
(keyboard problem mapping ctrl-alt-Backspace to something like Uparrow?), so I
then started Firefox, asking for last session. True to form, it went to all the
open pages _and_ a new tab for www.s.com. Next, I started Firefox without the
old pages, start page is the (non-existent) http://www.s.com.

Edit -> Preferences -> Main shows blank for the homepage. Some nutty control
character snuck in there making Firefox "auto-complete" the http://www._.com

Maybe we should register that one, and rent the space for advertising ;-)
Comment 6 Horst H. von Brand 2008-02-29 18:12:14 EST
firefox-3.0-0.beta3.30.nightly20080228.fc9.i386, and still www.s.com
Comment 7 Horst H. von Brand 2008-03-02 17:43:57 EST
firefox-3.0-0.beta3.32.nightly20080301.fc9.i386, still the same.
Comment 8 Horst H. von Brand 2008-03-03 08:55:06 EST
firefox-3.0-0.beta3.33.nightly20080302.fc9.i386 and counting...
Comment 9 Martin Stransky 2008-03-03 11:18:07 EST
What happens if you back-up ~/.mozilla completely, move it some hidden location
and start the browser? 
Comment 10 Horst H. von Brand 2008-03-05 08:26:15 EST
Moved .mozilla to SAVE.mozilla and started firefox again, did ask not to import

Edit -> Preferences -> Main -> When  Minefeld starts has "Show my home page",
and ... -> Home Page is blank.

I guess I'll request another severity level, "Amusement Value" in Bugzilla ;-)
Comment 11 Martin Stransky 2008-03-05 10:56:40 EST
So it's the homepage somehow set in your profile. Closing as NOTABUG. Please
reopen if you find a way how to reproduce the "unchangeable" homepage problem.
Comment 12 Horst H. von Brand 2008-03-06 09:42:42 EST
No, it shows exactly the same problem. Sorry if that wasn't clear from comment 10.
Comment 13 Martin Stransky 2008-03-06 09:50:09 EST
if it's a bug the attach steps how to reproduce it after clear firefox
installation. Your broken local configuration isn't enough.
Comment 14 Horst H. von Brand 2008-03-06 10:02:32 EST
Sorry, I didn't understand comment 13. What do you want me to do?
Comment 15 Terje Røsten 2008-03-06 11:26:01 EST
I did see this in rawhide some time ago, seems to be fine now.

However the s in www.s.com must come from the following:

firefox %s

which for some reason don't expand the %s, however firefox expand the s to

Check your preferred application settings in the GNOME menu.

Comment 16 Horst H. von Brand 2008-03-06 15:21:38 EST
Right, running firefox from a gnome-terminal shows no http://www.s.com nonsense.
But it shows the start page twice...

Yes, my Gnome settings have  '/usr/bin/firefox "%s"' as browser, is this a Gnome
problem then?
Comment 17 Matěj Cepl 2008-03-06 16:49:42 EST
(In reply to comment #16)
> Yes, my Gnome settings have  '/usr/bin/firefox "%s"' as browser, is this a Gnome
> problem then?

Good idea -- let's blame control-center !
Comment 18 Terje Røsten 2008-03-06 17:06:06 EST
> Yes, my Gnome settings have  '/usr/bin/firefox "%s"' as browser, 
> is this a Gnome problem then?

Don't know, I set the default browser to Firefox from the list and now it works.

How does apps/packages get listed there in first place by gconf, desktop file or?

BTW: It believe I first saw this www.s.com problem with the firefox xulrunner split.

Comment 19 Bastien Nocera 2008-03-06 18:08:13 EST
Could you check whether this happens when launched from the applications menu?
Does it only happen when launching it from the panel?
Comment 20 John Poelstra 2008-03-06 22:07:54 EST
FWIW... I have the same problem running the latest builds obtained directly from
mozilla on Fedora 8 that I run from my home dir.  I recently purged my .gconf
directories and .mozilla and it didn't fix anyting
Comment 21 John Poelstra 2008-03-06 22:15:38 EST
Okay.... 5 seconds on google solves the problem for me

I deleted the directory where firefox was running from and unpacked the latest
tarball (3.0b5-2008-03-06).  Everything works fine and no www.s.com for a start
page.  This is on F8 BTW.
Comment 22 Horst H. von Brand 2008-03-07 06:53:54 EST
Re 19: Launched from the menu firefox shows the start page, as it should.

Re 20, 21: It definitely is the settings in the Gnome panel (see 16) that mess
things up. I wonder why it is set to '/usr/bin/firefox "%s"' in the first place,
there won't be any URL to substitute for %s when called from the panel.
Comment 23 Horst H. von Brand 2008-03-27 11:19:38 EDT
It went away for some days, now it is back...
Comment 24 Horst H. von Brand 2008-03-27 18:57:29 EDT
Found out that it seems to go for http://www.s.com only when using the nouveau
driver, and it goes to the Fedora start page with the nv driver.
Comment 25 Horst H. von Brand 2008-04-01 15:52:27 EDT
Scratch #24, it again goes for http://www.s.com
(firefox-3.0-0.51.beta5rc2.fc9.i386, control-center-2.22.0-3.fc9.i386, nv driver)
Comment 26 Bug Zapper 2008-05-14 01:41:28 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 27 Matěj Cepl 2008-05-14 06:22:00 EDT
*** Bug 446317 has been marked as a duplicate of this bug. ***
Comment 28 Ronald Warsow 2008-05-25 09:50:22 EDT
I saw this also on F9.
www.s.com is in ~/.mozilla/firefox/<your-profile-name>.default/sessionstore.js

firefox from menue is launched with "%u" and from the panel with "%s"
so the fix for me is panel-laucher with "%u" and a proper homepage of course.

Comment 29 Horst H. von Brand 2008-06-01 19:16:54 EDT
It went away, now it is back... firefox-3.0-0.65.cvs20080416.fc10.i386
Comment 30 Horst H. von Brand 2008-06-01 19:17:59 EDT
Sorry, add control-center-2.23.2-1.fc10.i386 to #29
Comment 31 Horst H. von Brand 2008-12-22 09:31:44 EST
Now control-center-2.25.3-1.fc11.x86_64.

It suddenly has the annoying habit of (trying to) show my homedir as a webpage. This is even worse than the idiocy of not finding http://www.s.com.

Wouldn't it be easier to just get the s.com domain, and install the default Fedora page there? ;-)
Comment 32 George Kraft 2009-01-12 09:38:11 EST
I'm seeing the same www.s.com startup page with firefox 3.0.5 on Fedora 10.
Comment 33 Bastien Nocera 2009-01-13 10:14:46 EST
It's a problem in the preferred-apps.patch of gnome-panel which doesn't swap '%s' (as used in the control-center's preferred apps capplet and settings) with a %u.
Comment 34 Matthias Clasen 2009-01-16 14:34:41 EST
Should be fixed in gnome-panel-2.25.3-5.fc11. 
You may have to remove ~/.local/share/applications/preferred-web-browser.desktop to see it.
Comment 35 Alfa Prakash 2009-02-19 08:54:08 EST
Right click on the firefox/Prefered Web Browser icon on the gnome-panel.
Click on properties
In the Launcher Proprties window , Delete the %s in the Command field

Start firefox.

I think that should solve the problem.

Note You need to log in before you can comment on or make changes to this bug.