Bug 435365 - iscsadm stderr displayed on screen during non-ibft iscsi install
iscsadm stderr displayed on screen during non-ibft iscsi install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Martin Sivák
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 15:46 EST by James Laska
Modified: 2013-09-02 02:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 12:59:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iscsi-stderr.patch (2.16 KB, patch)
2008-02-28 15:53 EST, James Laska
no flags Details | Diff

  None (edit)
Description James Laska 2008-02-28 15:46:27 EST
# TREE RHEL5.2-Server-20080225.2/ia64

During a non-ibft iscsi installation I see the following stderr messages near
the end of the install.  This installation was done over a serial console.

I suspect we are not capturing iscsiadm output when attempting to process and
iBFT firmware reads.

                                                                                
                 +-------------+ Post Install +--------------+                  
                 |                                           |                  
                 | Performing post install configuration...iscsiadm: Could not
read fw values.
                 |                                           |                 
              iscsiadm: Could not read fw
values.+-------------------------------------------+
Comment 1 James Laska 2008-02-28 15:53:09 EST
Created attachment 296261 [details]
iscsi-stderr.patch 

Proposed fix, adding stderr= keyword argument to iutil.execWithCapture() calls
Comment 3 Joel Andres Granados 2008-03-28 11:23:00 EDT
had a quick look at the code and I don't think that the patch in comment 1
really fixes the issue.  I'm basing my opinion on the fact that the
execWithCaputre redirects stderr to stdout by default.  Moreover stdout is
redirected to the rc variable. so nothing should appear on the screan.

have to look more closely into this.
Comment 6 Joel Andres Granados 2008-03-28 13:32:20 EDT
just made a test with nightly-Server-20080327/x86_64, I did not see the issue.
Comment 7 James Laska 2008-03-28 15:15:04 EDT
I've done several text-mode kickstart installs on ia64 ... and didn't observe
this problem.

However, to feel good I'd like to do a manual text-mode kickstart, but cannot
because bug#437773 is blocking me from adding an iSCSI device in text-mode.
Comment 8 Andy Lindeberg 2008-10-01 17:10:46 EDT
jlaska, can you do so now that 437773 has been fixed?
Comment 9 James Laska 2008-10-03 09:06:01 EDT
I can confirm that this was resolved.

Note You need to log in before you can comment on or make changes to this bug.