Bug 435367 - quirks that worked to allow suspend to work no longer do
quirks that worked to allow suspend to work no longer do
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Prarit Bhargava
Martin Jenner
: Desktop, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 15:58 EST by Suzanne Hillman
Modified: 2008-05-08 13:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-08 13:31:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file (848.37 KB, text/plain)
2008-02-28 15:58 EST, Suzanne Hillman
no flags Details

  None (edit)
Description Suzanne Hillman 2008-02-28 15:58:32 EST
Description of problem:
quirks that worked to allow suspend to work no longer do. This is as of
upgrading my machine from 5.1+released updates to the Client-20080225.0 Beta
candidate build. The visible results are blinking caps lock on resume,
presumably due to kernel panic.

Additionally, the log file appears to show it relating to the wireless driver:

Feb 28 15:31:41 localhost kernel: bcm43xx: PHY connected
Feb 28 15:31:41 localhost kernel: bcm43xx: Microcode rev 0x127, pl 0xe
(2005-04-18  02:36:27)
Feb 28 15:31:41 localhost kernel: bcm43xx: Radio turned on
Feb 28 15:31:41 localhost kernel: bcm43xx: Radio enabled by hardware
Feb 28 15:31:41 localhost kernel: bcm43xx: ASSERTION FAILED (radio_attenuation <
10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1489:bcm43xx_find_lopair()
Feb 28 15:31:41 localhost kernel: bcm43xx: WARNING: Writing invalid LOpair (low:
-23, high: 117, index: 120)
Feb 28 15:31:41 localhost kernel:  [<cc9cd24b>]
bcm43xx_phy_lo_adjust+0x1a3/0x1e5 [bcm43xx]
Feb 28 15:31:41 localhost kernel:  [<cc9ca33d>]
bcm43xx_radio_set_txpower_bg+0x1b2/0x1dd [bcm43xx]
Feb 28 15:34:51 localhost syslogd 1.4.1: restart.

Version-Release number of selected component (if applicable):
kernel-2.6.18-83.el5
hal-0.5.8.1-33.el5
pm-utils-0.99.3-6.el5.18

How reproducible:
Always

Steps to Reproduce:
1. Get an acer aspire 3002CLi, and suspend it with --quirk-vbe-post
--quirk-vbemode-restore
  
Actual results:
Kernel panic

Expected results:
Functional suspend like I used to have working.

Additional info:
I will check if using an older kernel allows this to work again.
Comment 1 Suzanne Hillman 2008-02-28 15:58:32 EST
Created attachment 296263 [details]
Log file
Comment 2 Suzanne Hillman 2008-02-28 16:08:44 EST
This works fine if the only thing I change is to use the 2.6.18-53.1.6.el5
kernel. Regression. Probably not important enough to block Beta (because it is
so specific), but setting regression keyword.
Comment 3 Suzanne Hillman 2008-05-08 13:31:40 EDT
Seems to be working fine again on 2.6.18-92.el5

Note You need to log in before you can comment on or make changes to this bug.