Bug 435381 - rhpxl fails on HP ilo2 based systems with: TypeError: Expected a string
rhpxl fails on HP ilo2 based systems with: TypeError: Expected a string
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhpxl (Show other bugs)
5.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Adam Jackson
: Regression, Reopened
: 437303 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 17:04 EST by Doug Chapman
Modified: 2010-10-22 18:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0383
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:48:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to replace missing quotes in get_option assignments (1.07 KB, patch)
2008-02-28 17:04 EST, Doug Chapman
no flags Details | Diff
updates.img to test fix (1.41 MB, application/octet-stream)
2008-02-28 18:55 EST, Micah Parrish
no flags Details

  None (edit)
Description Doug Chapman 2008-02-28 17:04:08 EST
Description of problem:
This issue blocks installing on HP Integrity servers w/ilo2 and quite likely
breaks proliant ilo2 systems as well (I still need to verify the proliant end).

There was a patch recently from HP to enable ilo2 virtual mouse in rhxpl. 
Something changed in the patch (patch as attached to the BZ was incorrect as
well, not blaming Red Hat here!) and some values that had ben strings got
changed to integers (i.e. the quotes were removed around some numeric values).

I am attaching a patch, I don't have a way to test this (is there a way to run
rhpxl outside of anaconda?) but it brings the code inline with what HP had
submitted.



Version-Release number of selected component (if applicable):
rhpxl-0.41.1-5.el5


How reproducible:
100%

Steps to Reproduce:
1. install on an HP ilo2 system
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-02-28 17:04:08 EST
Created attachment 296272 [details]
patch to replace missing quotes in get_option assignments
Comment 2 RHEL Product and Program Management 2008-02-28 17:28:29 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 RHEL Product and Program Management 2008-02-28 17:30:26 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 4 Micah Parrish 2008-02-28 18:55:40 EST
Created attachment 296290 [details]
updates.img to test fix
Comment 5 Doug Chapman 2008-02-28 19:08:24 EST
I have booted with micha's updates.img file and it does fix the issue on the HP
rx6600 Integrity server.

So far I have not been able to get it to fail on the bl685c proliant system I am
testing on.  It appears the code is never getting executed there as it should. 
My current guess is the older firmware on this box is to blame and I am updating
the firmware to test that.  I don't know if all proliant boxes will avoid the
crash or not.  In theory they should execute the code and hit the same problem
described above.
Comment 6 Adam Jackson 2008-03-03 16:21:48 EST
Devel ack, trivial.
Comment 7 Adam Jackson 2008-03-07 13:28:18 EST
Built as rhpxl 0.41.1-6.el5.  MODIFIED.
Comment 8 Micah Parrish 2008-03-10 18:19:59 EDT
0.41.1-6.el5 didn't make it into Beta 1.  Can we expect it in Beta 2?  This bug
is making our install testing difficult.
Comment 9 Doug Chapman 2008-03-13 10:55:52 EDT
*** Bug 437303 has been marked as a duplicate of this bug. ***
Comment 10 Rick Hester 2008-03-19 17:00:27 EDT
It appears that rhpxl-0.41.1-5.el5.ia64 is also in the Snapshot1 
image.  This is making testing very difficult.  

I'm going to make an issue tracker for this problem to increase the visibility.
Comment 11 Doug Chapman 2008-03-24 13:02:58 EDT
This is still broken as of the latest internal nightly build:

RHEL5.2-Server-20080321.nightly

Can we get this pulled into the RHEL5 build?
Comment 15 Adam Jackson 2008-03-24 14:12:12 EDT
Should be in the next nightly.
Comment 16 Cameron Meadors 2008-04-16 14:14:01 EDT
Can someone with this hardware please test the fix?
Comment 17 Micah Parrish 2008-04-16 16:59:48 EDT
Fixed in snapshot 4, thanks.
Comment 19 Cameron Meadors 2008-04-23 11:42:47 EDT
Verified per comment #17
Comment 22 errata-xmlrpc 2008-05-21 12:48:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0383.html

Note You need to log in before you can comment on or make changes to this bug.