Bug 435416 - Error while running application in locale
Error while running application in locale
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 02:19 EST by A S Alam
Modified: 2013-07-02 20:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 11:08:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2008-02-29 02:19:27 EST
Description of problem:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/firstboot/interface.py", line 262, in
createScreens
    module.createScreen()
  File "/usr/share/firstboot/modules/keyboard.py", line 139, in createScreen
    if not self.kbd.beenset:
AttributeError: 'NoneType' object has no attribute 'beenset'


Since there is a problem, firstboot will exit.

Please file a bug against 'firstboot' in the Red Hat
bug tracking system at http://www.redhat.com/bugzilla.
A copy of the debug output has been saved to /tmp/firstboot-ns_n13
Be sure to attach that file to the bug report.

Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.12-1.fc9.noarch
firstboot-1.92-1.fc9.i386

How reproducible:
Everytime with as_IN locale

Steps to Reproduce:
1. use LANG=as_IN.UTF-8
2.firstboot --reconfig --debug
3.
  
Actual results:
Error on Terminal and in a Window

Expected results:
should not have

Additional info:
Another bug for smolt: (bug: 432305)
Terminal also showing error:
firstboot --reconfig --debug
firstboot INFO: Starting up in reconfig mode
firstboot DEBUG: X is already running, not using any frontend

(firstboot:3444): Gtk-WARNING **: Whoever translated default:LTR did so wrongly.

firstboot DEBUG: Successfully loaded module eula, adding
firstboot DEBUG: Successfully loaded module welcome, adding
firstboot ERROR: Module language does not contain a class named moduleClass;
skipping.
firstboot DEBUG: Successfully loaded module create_user, adding
firstboot INFO: skipping module additional_cds because shouldAppear returned false
firstboot DEBUG: Successfully loaded module smolt, adding
firstboot DEBUG: Successfully loaded module keyboard, adding
firstboot DEBUG: Using GTK interface
firstboot CRITICAL: Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/firstboot/interface.py", line 262, in
createScreens
    module.createScreen()
  File "/usr/share/firstboot/modules/keyboard.py", line 139, in createScreen
    if not self.kbd.beenset:
AttributeError: 'NoneType' object has no attribute 'beenset'

Loading simple Config module ...
Creating backend ...
Reading pinyin phrase lib failed
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Reading pinyin phrase lib failed
Comment 1 A S Alam 2008-02-29 02:22:18 EST
it is showing error with en_US.UTF-8, so changed to desktop error
Comment 2 Chris Lumens 2008-02-29 11:08:58 EST
This will be fixed in the next build of system-config-keyboard.

Note You need to log in before you can comment on or make changes to this bug.