Bug 435425 - compilation of prelink failed on i386 and ppc
compilation of prelink failed on i386 and ppc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 04:29 EST by Stefan Schulze Frielinghaus
Modified: 2008-03-01 07:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-01 07:02:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Schulze Frielinghaus 2008-02-29 04:29:32 EST
Description of problem:
I cannot build prelink from source rpm. After executing rpmbuild -bb --clean
prelink.spec I get the following error:

checking libelf.h usability... no
checking libelf.h presence... yes
configure: WARNING: libelf.h: present but cannot be compiled
configure: WARNING: libelf.h: check for missing prerequisite headers?
configure: WARNING: libelf.h: proceeding with the preprocessor's result
configure: WARNING:     ## ------------------------------------ ##
configure: WARNING:     ## Report this to bug-autoconf@gnu.org. ##
configure: WARNING:     ## ------------------------------------ ##
checking for libelf.h... yes
checking gelf.h usability... no
checking gelf.h presence... yes
configure: WARNING: gelf.h: present but cannot be compiled
configure: WARNING: gelf.h: check for missing prerequisite headers?
configure: WARNING: gelf.h: proceeding with the preprocessor's result
configure: WARNING:     ## ------------------------------------ ##
configure: WARNING:     ## Report this to bug-autoconf@gnu.org. ##
configure: WARNING:     ## ------------------------------------ ##
checking for gelf.h... yes
checking for elf_begin in -lelf... yes
checking for gelf_getvernaux... yes
checking whether FTW_ACTIONRETVAL is supported... yes
checking for is_selinux_enabled in -lselinux... yes
checking selinux/selinux.h usability... yes
checking selinux/selinux.h presence... yes
checking for selinux/selinux.h... yes
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for _LARGE_FILES value needed for large files... no
configure: error: libelf does not properly convert Elf64_Sxword quantities.
If you are using libelf-0.7.0, please use patches/libelf-0.7.0.patch.
error: Bad exit status from /var/tmp/rpm-tmp.84088 (%build)

Are there some dependencies missing? I tried it on i386 and ppc Fedora 8.

Version-Release number of selected component (if applicable):
0.4.0-1

How reproducible:
always

Steps to Reproduce:
rpmbuild -bb --clean prelink.spec
Comment 1 Stefan Schulze Frielinghaus 2008-03-01 07:02:58 EST
The problem was solved in the elfutils package version 0.132 (which is in
testing/rawhide). So it wasn't a direct problem of prelink. For reference see
this post:
http://linux.derkeiler.com/Mailing-Lists/Fedora/2008-01/msg02960.html

Note You need to log in before you can comment on or make changes to this bug.