Bug 435426 - test5 basic connectathon tests fail between RHEL5.1 and AIX 6.1.0 SP2 [NEEDINFO]
test5 basic connectathon tests fail between RHEL5.1 and AIX 6.1.0 SP2
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 04:44 EST by Aime Le Rouzic
Modified: 2014-05-21 13:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-21 13:14:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (aime.le-rouzic)


Attachments (Terms of Use)

  None (edit)
Description Aime Le Rouzic 2008-02-29 04:44:07 EST
Description of problem:

Having a configuration in which the server is RHEL5.1 Gold and the client is 
AIX 6.1.0 SP2, when I run the test5 basic command (-b) of the connectathon suite
on AIX after doing a NFSV4 mount I get the following errors: 

./runtests -b -t /mnt/nosec/test5
Starting BASIC tests: test directory /mnt/nosec/test5 (arg: -t)
./test5: read and write
./test5: (/mnt/nosec/test5) 'bigfile' has size 1048576, should be 0
basic tests failed


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
We have the error because the asked TRUNCATION is ineffective. If we suppress
the TRUNCTATION in the test5, it works.

 On the AIX side, open and truncate the file are done all at once. but 
linux looks to split it into two operations, it opens first and then truncate.

Another analyse on the AIX side gives the following:
>At this point the file size is 1048576.
>>The client send the following compound request over to the server.


>>OP_PUTFH
>>OP_OPEN, with size of 0.
>>OP_NVERIFY, with the file verifier when the file size is 1048576.
>>OP_GETATTR
>>OP_GETFH


>>The server reply with


>>OP_PUTFH --- NFS4_OK
>>OP_OPEN --- NFS4_OK
>>OP_NVERIFY --- NFS4ERR_SAME


>>One would think that if server return NFS4_OK for OP_OPEN that OP_OPEN
>operation was successful and that the file size has been truncated to 0. And
>since file size has been truncated from 1048576 to 0. So the file verifier
>should be different than the one that client sent (the one when the file size
>is 1048576). Which means the OP_NVERIFY should return NFS4_OK because it's not
>the same. But in this case, linux actually return the same. I think this is a
>linux bug.


>>Keep in mind that I do believe there is a limitation on one fo the linux's
>filesystem that the time_delta is 1 seconds. That will most definitely cause
>this. In term of which filesystem it is.


The file system on the linux server is ext3.
Comment 1 RHEL Product and Program Management 2008-07-25 13:05:29 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Ludek Smid 2008-07-25 17:55:21 EDT
Unfortunately the previous automated notification about the
non-inclusion of this request in Red Hat Enterprise Linux 5.3 used
the wrong text template. It should have read: this request has been
reviewed by Product Management and is not planned for inclusion
in the current minor release of Red Hat Enterprise Linux.

If you would like this request to be reviewed for the next minor
release, ask your support representative to set the next rhel-x.y
flag to "?" or raise an exception.
Comment 3 RHEL Product and Program Management 2014-03-07 07:50:16 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Note You need to log in before you can comment on or make changes to this bug.