This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 435446 - b43: Cannot connect to ad-hoc network
b43: Cannot connect to ad-hoc network
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 07:27 EST by Robin Green
Modified: 2008-05-13 14:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 14:38:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of iwconfig (572 bytes, text/plain)
2008-02-29 12:48 EST, Robin Green
no flags Details
/var/log/messages (44.75 KB, text/plain)
2008-02-29 12:48 EST, Robin Green
no flags Details
updated /var/log/messages (95.61 KB, text/plain)
2008-02-29 13:12 EST, Robin Green
no flags Details
wireshark capture of wmaster1 (72.41 KB, application/octet-stream)
2008-03-16 18:49 EDT, Robin Green
no flags Details
ifcfg-wlan0 (367 bytes, text/plain)
2008-03-18 05:25 EDT, Robin Green
no flags Details
ifcfg-wlan1 (335 bytes, text/plain)
2008-03-18 05:26 EDT, Robin Green
no flags Details

  None (edit)
Description Robin Green 2008-02-29 07:27:51 EST
Description of problem:
I have tried to create an ad-hoc network with ESSID "Home Network", between a
Fedora 8 machine with a Broadcom BCM4318 (using the b43 driver), and a Windows
XP machine with an Intel wireless chipset and the latest drivers. Whether I
bring up the network on the Windows side first or the Linux side first, I fail
to establish a connection between the two machines. dhcpd is running on the
Fedora box.

Version-Release number of selected component (if applicable):
kernel-2.6.24.3-12.fc8
kernel-2.6.24.2-7.fc8

How reproducible:
Always

Steps to Reproduce:
1. Create ad-hoc network on Windows machine with ESSID "Home Network", no security
2. Using system-config-networking, set wlan0 to ad-hoc mode with same ESSID, no
security, static IP address
3. Configure a DHCP server to start on bootup on the Fedora box
4. Reboot fedora (sometimes b43 doesn't "take" new settings until after a reboot)
  
Actual results:
Windows box reports "adhoc network has no peers"

Expected results:
Connection established

Additional info:
I am also unable to connect between my Gentoo box with the an acx111 (acx
driver) and either the Windows machine or the Fedora machine. So none of the
three machines is able to connect to any of the others wirelessly.

I don't have an AP currently to test with that, but I'll try and borrow one.
Comment 1 Robin Green 2008-02-29 07:29:49 EST
That should say "system-config-network", not "system-config-networking", above.
Comment 2 John W. Linville 2008-02-29 09:03:51 EST
Please attach the output of running iwconfig after a connection attempt.  Also 
attach the contents of /var/log/messages.

I may also need you to run wireshark to capture your connection attempt as 
well, but please go ahead and attach the above requested information ASAP in 
case the wireshark capture is unnecessary...thanks!
Comment 3 Robin Green 2008-02-29 12:48:07 EST
Created attachment 296389 [details]
output of iwconfig
Comment 4 Robin Green 2008-02-29 12:48:48 EST
Created attachment 296390 [details]
/var/log/messages
Comment 5 Robin Green 2008-02-29 12:50:13 EST
Thanks! Happy to provide any other needed info.
Comment 6 Robin Green 2008-02-29 13:12:17 EST
Created attachment 296392 [details]
updated /var/log/messages

Oops! I forgot that the radio was disabled. I turned on the radio and rebooted
(as you can see in the log).
Comment 7 Robin Green 2008-03-16 17:22:01 EDT
I just got a rt2500-based PCMCIA card, and I have the same issue with that (same
machine). If I bring both wlan0 and wlan1 up in ad-hoc mode, neither of them
tries to merge their networks with the other, at least judging by dmesg. So
maybe there is a bug in some common code?

I assume I should run wireshark now...
Comment 8 Robin Green 2008-03-16 18:49:06 EDT
Created attachment 298222 [details]
wireshark capture of wmaster1

I also ran wireshark on the Windows side while trying to connect, but it did
not capture any packets.
Comment 9 John W. Linville 2008-03-17 14:56:04 EDT
Could you post the exact sequence of commands you are using to create your 
ad-hoc network?  Thanks!
Comment 10 Robin Green 2008-03-17 15:43:18 EDT
By the way: I just realised you might have thought that it was just a "radio
disabled" mistake, originally, because of my comment #6. It wasn't - after I
reenabled the radio it still failed to work.

I created the network with system-config-network, so I just use the Activate
button in that program, or type "ifup wlan[0/1]". (The DHCP server is started by
its initscript on bootup.)
Comment 11 John W. Linville 2008-03-17 16:39:21 EDT
Sure, OK...can you attach the contents of ifcfg-wlan0 and ifcfg-wlan1?
Comment 12 Robin Green 2008-03-18 05:25:57 EDT
Created attachment 298355 [details]
ifcfg-wlan0

wlan0 is the b43.
Comment 13 Robin Green 2008-03-18 05:26:39 EDT
Created attachment 298356 [details]
ifcfg-wlan1
Comment 14 Robin Green 2008-03-18 05:27:51 EDT
*adding bogus comment to change bug status back*
Comment 15 John W. Linville 2008-03-18 14:15:25 EDT
I cannot replicate this using two F8 systems running kernel-2.6.24.3-34.fc8, 
one with b43 and one with iwl3945.

Please attch the output of running 'chkconfig --list'?

Also, excuse me for asking but you are executing 'ifup wlan0' and 'ifup wlan1' 
right?  Sorry, I have to ask...
Comment 16 Ahmed G. 2008-03-30 18:35:15 EDT
  I am having similar problems on a Dell Wireless card using the b43/ssb
drivers. Specifically I cannot create and ad-hoc network. I have not tried
connecting to an existing one. This is true for both rawhide and Fedora 8.
Comment 17 John W. Linville 2008-03-31 10:05:27 EDT
Ahmed, how are you attempting to create the network?  Please be specific.

As I indicated in comment 15, I cannot recreate this issue.  I'll need you to 
describe what you are doing in detail.
Comment 18 John W. Linville 2008-05-13 14:38:54 EDT
Closed due to lack of response...please reopen when the requested information 
becomes available -- thanks!

Note You need to log in before you can comment on or make changes to this bug.