Bug 435451 - Remove the unused --target option from kickstart
Remove the unused --target option from kickstart
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pykickstart (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Chris Lumens
:
Depends On: 435383
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 09:12 EST by James Laska
Modified: 2013-09-02 02:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-28 16:59:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iscsi-target-node.patch (2.21 KB, patch)
2008-02-29 09:12 EST, James Laska
no flags Details | Diff
iscsi-target-node.patch (2.94 KB, patch)
2008-02-29 13:38 EST, James Laska
no flags Details | Diff

  None (edit)
Description James Laska 2008-02-29 09:12:39 EST
The kickstart iscsi keyword accepts a --target option.  It does not appear that
this value is used during iscsi bring up.  For documentation details on the
iscsi kickstart parameter, see
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/en-US/RHEL510/Installation_Guide/s1-kickstart2-options.html.

The attached patch ensures that only the requested target (aka node) on the
given  iSCSI ipaddr is used.

To complete the fix, the pykickstart bug#435383 will need to be included as well.
Comment 1 James Laska 2008-02-29 09:12:39 EST
Created attachment 296352 [details]
iscsi-target-node.patch
Comment 2 James Laska 2008-02-29 09:57:55 EST
Hrmm, scratch this ... that patch in comment#1 won't work because there appears
that the startup() method does a discover and adds nodes long before we get to
hte addTarget() calls.
Comment 3 James Laska 2008-02-29 11:34:23 EST
... reworking ...
Comment 4 James Laska 2008-02-29 13:38:32 EST
Created attachment 296401 [details]
iscsi-target-node.patch

Updated patch ... not sure if this is the right thing to do ... but it's tested
and works when a kickstart contains:

iscsiname iqn.foo.bar
iscsi --target $IP --port $PORT 

  and

iscsiname iqn.foo.bar
iscsi --target $IP --port $PORT --target iqn.2008-01.com.redhat:iscsi1

  and

iscsiname iqn.foo.bar
iscsi --target $IP --port $PORT --target iqn.2008-01.com.redhat:iscsi0
iscsi --target $IP --port $PORT --target iqn.2008-01.com.redhat:iscsi1
Comment 5 James Laska 2008-02-29 13:53:07 EST
After discussion with Mike Christie on the iscsiadm tools side of things, it
sounds like there isn't any demand/need for --target based filtering.  Any
filtering is done on the server by using the client initiatorname or ACLs.

Perhaps this bug should be to remove the --target kickstart option altogether?
Comment 7 RHEL Product and Program Management 2010-04-28 16:59:33 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.