Bug 435459 - Firefox crashes when flash microphone properites tab clicked
Summary: Firefox crashes when flash microphone properites tab clicked
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-29 14:57 UTC by Kim van der Riet
Modified: 2018-04-11 07:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-24 14:39:22 UTC


Attachments (Terms of Use)
BugBuddy bug report for crash (41.92 KB, text/plain)
2008-02-29 14:57 UTC, Kim van der Riet
no flags Details

Description Kim van der Riet 2008-02-29 14:57:05 UTC
Description of problem:
If one left-clicks on any flash instance on a web page and selects the
properties menu item, an Adobe settings window appears. On the bottom edge of
this window are a number of tabs containing icons. Clicking on the microphone
icon causes a firefox crash.

Version-Release number of selected component (if applicable):
Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12)
Gecko/0000000000 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

How reproducible:
Always

Steps to Reproduce:
1. Start firefox.
2. Open Adobe's home page (www.adobe.com).
3. Left-click on the flash presentation near the top of the page.
4. Select Properties. A small "Adobe Flash Player Settings" dialog appears.
5. Click on the microphone tab (fourth tab from left).
6. Firefox crashes after a slight delay (probably caused by BugBuddy starting.

Actual results:
Firefox crashes.

Expected results:
No crash.

Additional info:
I loaded all the relevant debug info packages I could find. Although this may be
a flash bug, the assert is occurring in pcm_params.c from a call to
sndrv_pcm_hw_params (see attached bug report).

I'd be happy to do additional debugging if that is required.

cat /proc/asound/cards
 0 [ICH6           ]: ICH4 - Intel ICH6
                      Intel ICH6 with AD1980 at irq 21

cat /proc/asound/modules 
 0 snd_intel8x0

cat /proc/asound/pcm 
00-04: Intel ICH - IEC958 : Intel ICH6 - IEC958 : playback 1
00-03: Intel ICH - ADC2 : Intel ICH6 - ADC2 : capture 1
00-02: Intel ICH - MIC2 ADC : Intel ICH6 - MIC2 ADC : capture 1
00-01: Intel ICH - MIC ADC : Intel ICH6 - MIC ADC : capture 1
00-00: Intel ICH : Intel ICH6 : playback 1 : capture 1

cat /proc/asound/version 
Advanced Linux Sound Architecture Driver Version 1.0.15 (Tue Nov 20 19:16:42
2007 UTC).

Comment 1 Kim van der Riet 2008-02-29 14:57:05 UTC
Created attachment 296361 [details]
BugBuddy bug report for crash

Comment 2 Kim van der Riet 2008-02-29 15:02:13 UTC
Oops, I should have added: AdobeReader_enu-8.1.2-1

Comment 3 Kim van der Riet 2008-02-29 16:52:04 UTC
It seems I can't tell my left from my right: In point 3 above
s/Left-click/Right-click/

Comment 4 Matěj Cepl 2008-10-24 14:39:22 UTC
OK, this is crash in flash-plugin -- nothing we can make anything about here.


Note You need to log in before you can comment on or make changes to this bug.