Bug 435484 - Available Channel Entitlements is shown as -1 for channel family in an upgraded satellite.
Available Channel Entitlements is shown as -1 for channel family in an upgrad...
Status: CLOSED DUPLICATE of bug 435894
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
510
All Linux
medium Severity medium
: ---
: ---
Assigned To: Clifford Perry
Preethi Thomas
https://fjs-0-13.rhndev.redhat.com/rh...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 11:53 EST by Preethi Thomas
Modified: 2008-09-18 15:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 15:44:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2008-02-29 11:53:35 EST
Description of problem:
Available Channel Entitlements is shown as -1 for channel family in an upgraded
satellite.

Version-Release number of selected component (if applicable):
rhn-satellite-5.1.0-167-redhat-linux-as-i386-4-embedded-oracle.iso

How reproducible:


Steps to Reproduce:
1. On your 5.0 satellite create custom channel and subscribe it as the base
channel for a system.
2. upgrade a 5.0 satellite.
3. activate the upgraded satellite with shughes-test-virt.cert
4. create a new organization and give channel and system entitlement for the
organization.
5. Go to Your RHN-> Subscription Management->Software channel Entitlements
7. See the Available channel entitlement for the  Shannon Hughes (1) Channel Family 
  
Actual results:
Channel Entitlement	Systems Entitled	Available Entitlements
 Shannon Hughes (1) Channel Family 	  1  	 -1


Expected results:
Available Entitlements can not be negative.

Additional info:
Comment 1 Clifford Perry 2008-02-29 13:09:22 EST
this may webui only issue - does it stop you from using custom channels?
Comment 2 Clifford Perry 2008-02-29 13:50:03 EST
going to review Sat 5.1 system - fjs-0-13
Comment 3 Clifford Perry 2008-02-29 14:19:06 EST
oohh... this is not an upgrade, nor multi-org issue.

I am able to use private/custom channels fine... 

Looking at rlx-1-12 - Sat 5.0, rlx-1-14 - Sat 4.2, rlx-1-16 - Sat 4.2 - they all
have negative numbers which continue to decrease as more and more systems are
using custom channels. 

As such, this is a webui issue, not impacting on function of Satellite 5.1, so
moving along. We wont look to change code, this late, to fix a display issue :/ 

Cliff. 
Comment 5 Brandon Perkins 2008-09-18 15:44:00 EDT

*** This bug has been marked as a duplicate of bug 435894 ***

Note You need to log in before you can comment on or make changes to this bug.